summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThiago Macieira <thiago.macieira@intel.com>2022-11-23 12:19:17 -0800
committerThiago Macieira <thiago.macieira@intel.com>2022-11-24 01:28:07 -0800
commit980e2f2a3f40521ce68e1f563c731b18984e64c8 (patch)
treef7e14f67896bd118ae262f74ab9a0cae23e619a4 /CMakeLists.txt
parent0e5099cc5afaef043058a6b3b459aa7e815ddf9c (diff)
CMake: fix build: qtshadertools may be required
CMake Error at src/plugins/renderers/rhi/rhi.cmake:7 (target_link_libraries) Error evaluating generator expression: $<TARGET_PROPERTY:Qt6::ShaderTools,_qt_module_has_private_headers> Target "Qt6::ShaderTools" not found. Call Stack (most recent call first): tests/auto/render/rhi/rhi_renderviews/CMakeLists.txt:21 (qt3d_setup_rhi_renderer_target) Pick-to: 6.4 Change-Id: I76216ced393445a4ae2dfffd172a502aec56333b Reviewed-by: Jörg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5412b4518..6fd634b1b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,7 +16,7 @@ project(Qt3D # special case
# special case begin
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
- Network Concurrent Widgets Qml Quick Gamepad OpenGL Multimedia)
+ Network Concurrent Widgets Qml Quick ShaderTools Gamepad OpenGL Multimedia)
# special case end
if(NOT TARGET Qt::Gui)