summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2023-04-12 15:04:14 +0200
committerAlexey Edelev <alexey.edelev@qt.io>2023-05-31 13:56:03 +0200
commitaab1bc000f67602603810750843695a4005f599c (patch)
treedf5183c9d8abf48dde74373850948ded3ea400c6 /CMakeLists.txt
parent920382c85c7933d0ca8f1cffb81aaaa17af2560d (diff)
Add the use of the qt_internal_project_setup function
The function sets the required CMake variables and policies. Pick-to: 6.5 Task-number: QTBUG-112685 Change-Id: I84d24c8ac2bc0979152554142d80b3eb53f30856 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fbd6bb51d..0ab52d30f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,8 @@ find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
Network Concurrent Widgets Qml Quick ShaderTools Gamepad OpenGL Multimedia QuickWidgets)
# special case end
+qt_internal_project_setup()
+
if(NOT TARGET Qt::Gui)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")
return()