summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLi Xinwei <1326710505@qq.com>2021-01-13 20:05:14 +0800
committerLi Xinwei <1326710505@qq.com>2021-01-13 21:26:38 +0800
commit89ed430fe6e09a5b2f5e75840f51604083ac54f5 (patch)
treee0a2deec634bfbd5e78f4d382f819f9b37ea62fb /CMakeLists.txt
parentd6e67961e9e3d0358411ea8caafe15cce5d84fca (diff)
Don't hardcode version number in CMakeLists.txt
The version number should depend on .cmake.conf. Pick-to: 6.0 Change-Id: I1ef7713d7dbf3ee5f0abdf7f9d8ff0fb89cdb6dc Reviewed-by: Alexey Edelev <alexey.edelev@qt.io> Reviewed-by: Mike Krus <mike.krus@kdab.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7cfdce7cf..cc3e925c9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,8 +2,9 @@
cmake_minimum_required(VERSION 3.15.0)
+include(.cmake.conf)
project(Qt3D # special case
- VERSION 6.0.0
+ VERSION "${QT_REPO_MODULE_VERSION}"
DESCRIPTION "Qt 3D Libraries" # special case
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C