summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-10-20 16:42:09 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-10-20 18:55:42 +0200
commitb87b0cc89ffee4ffc01a714e705caf8e247bd233 (patch)
treef109fa216fe69171f4d8a0fa65bcebcf5928dfe1 /CMakeLists.txt
parente25cd0b8b81b3ddd373a4d13ee303d37a5fb5a8a (diff)
CMake: Make optional components that are not found more quiet
Doesn't display a big stack trace warning, instead just saying that the component was not found. Change-Id: I07780f34c865b854573e8acd5399a7a9253d7ff3 Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f43e3a151..7c41a9ed4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,11 +12,11 @@ project(Qt3D # special case
# special case begin
# Make sure we only use latest private CMake API, aka no compatibility wrappers.
set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
-# special case end
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui
- OPTIONAL_COMPONENTS Concurrent Widgets Qml Quick Gamepad OpenGL ShaderTools
-)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui)
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG
+ OPTIONAL_COMPONENTS Concurrent Widgets Qml Quick Gamepad OpenGL ShaderTools)
+# special case end
if(NOT TARGET Qt::Gui)
message(FATAL_ERROR "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")