summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Krus <mike.krus@kdab.com>2020-11-14 10:17:35 +0000
committerMike Krus <mike.krus@kdab.com>2020-11-20 11:59:42 +0000
commitba9827ab5de200756f5c2c0899fc01f1d573eae2 (patch)
treec591d5a38559ec1e2cf0435930c4b32a79c25e14 /CMakeLists.txt
parent9e2770d8995aedb07c517dd31395c8bb3a605def (diff)
Follow up on change of QQmlListProperty to qsizetype
Also update dependencies and fix non-gui builds. Disabled (for now) gltf unit test since JSON parser seems to crash. Change-Id: Ie7fdd9626653e89ad43e8bdb22b0e764618b1e9e Reviewed-by: Paul Lemire <paul.lemire@kdab.com> Reviewed-by: Mike Krus <mike.krus@kdab.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7c41a9ed4..7cfdce7cf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,17 +13,17 @@ project(Qt3D # special case
# Make sure we only use latest private CMake API, aka no compatibility wrappers.
set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui)
-find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG
- OPTIONAL_COMPONENTS Concurrent Widgets Qml Quick Gamepad OpenGL ShaderTools)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
+ Concurrent Widgets Qml Quick Gamepad OpenGL ShaderTools)
# special case end
if(NOT TARGET Qt::Gui)
- message(FATAL_ERROR "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")
+ message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")
return()
endif()
if(WASM OR NOT QT_FEATURE_opengl)
- message(FATAL_ERROR "Skipping the build as the condition \"QT_FEATURE_opengl AND NOT WASM\" is not met.")
+ message(NOTICE "Skipping the build as the condition \"QT_FEATURE_opengl AND NOT WASM\" is not met.")
return()
endif()