summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorSarah Smith <sarah.j.smith@nokia.com>2011-04-04 20:35:10 +1000
committerSarah Smith <sarah.j.smith@nokia.com>2011-04-04 20:35:10 +1000
commitce4b14604cb967e0b6160afa738420580d4b2cf3 (patch)
tree41aa00b1c04ee8929eec831f44b181b95c885bae /debian
parentce5d8672678f64afbdd67b7992362693f516c43d (diff)
Packaging round one done.
See QTBUG-17434 for more details. Packaging on a debian desktop system works. Tested with Ubuntu 10.10 which is currently one of few with Qt 4.7.x packages.
Diffstat (limited to 'debian')
-rw-r--r--debian/libqt4-3d-examples.install2
-rwxr-xr-xdebian/rules32
2 files changed, 23 insertions, 11 deletions
diff --git a/debian/libqt4-3d-examples.install b/debian/libqt4-3d-examples.install
index 610e3dc20..130f8c80f 100644
--- a/debian/libqt4-3d-examples.install
+++ b/debian/libqt4-3d-examples.install
@@ -1,2 +1,2 @@
usr/bin/*
-usr/share/qt4/demos/declarative/
+usr/share/qt4/quick3d
diff --git a/debian/rules b/debian/rules
index 70021466d..2ed9da76f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,9 +2,22 @@
# -*- makefile -*-
# To build using this rules file:
-# mkdir qt3d-1.0
-# (cd ~/depot/research/qt3d && tar cf - --exclude-vcs .)|(cd qt3d-1.0 && tar xvpf -)
-# cd qt3d-1.0
+# #
+# ### install debian packaging stuff if not already present:
+# sudo apt-get install dpkg-dev debhelper cdbs
+#
+# ### set up the build directory with version number - DO NOT CD INTO IT YET!
+# mkdir quick3d-tp1
+#
+# ### copy all the stuff across - cannot shadow build (probably don't want git)
+# (cd ~/depot/qt/quick3d && tar cf - --exclude-vcs .)|(cd quick3d-tp1 && tar xf -)
+#
+# ### if the qmake in the $PATH is not the Qt you want to use
+# ### you can use a binary package or a Qt built from source (even if its installed with
+# ### "make install") as long as it has declarative & opengl
+# # export PATH=/usr/local/Trolltech/Qt-4.7.2/bin:$PATH
+#
+# cd quick3d-tp1
# export DEB_BUILD_OPTIONS="parallel=4"
# dpkg-buildpackage -b
@@ -22,15 +35,14 @@ ifneq (,$(filter parallel=%,$(TMP_BUILD_OPTS)))
PARALLEL_MAKEFLAGS += -j$(NUMJOBS)
endif
+ifeq (arm,$(findstring arm,$(shell g++ -v 2>&1 | sed -n '/Target: arm/p')))
+ QMAKE_CONF_MKSPEC = "-spec linux-g++-maemo"
+ QMAKE_CONF_OPTS = "CONFIG+=maemo"
+endif
+
DEB_MAKE_INVOKE := $(MAKE) $(PARALLEL_MAKEFLAGS)
DEB_MAKE_INSTALL_TARGET := INSTALL_ROOT=$(DEB_DESTDIR) install
DEB_DH_INSTALL_SOURCEDIR := debian/tmp
common-configure-arch::
- qmake -spec linux-g++-maemo opengl.pro CONFIG+=maemo
-
-common-install-arch:: install-examples
-
-install-examples:
- cp -a bin $(DEB_DESTDIR)/usr
- cp -a demos/declarative $(DEB_DESTDIR)/usr/share/qt4
+ qmake $(QMAKE_CONF_MKSPEC) quick3d.pro $(QMAKE_CONF_OPTS) CONFIG+=package