summaryrefslogtreecommitdiffstats
path: root/examples/qt3d/advancedcustommaterial/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Krus <mike.krus@kdab.com>2020-05-08 14:06:53 +0100
committerMike Krus <mike.krus@kdab.com>2020-05-22 08:53:50 +0100
commit22dd30949938083aceda8267c41c920c61c0d388 (patch)
treea49704414a853624006b860d1a92689bc4f5ca88 /examples/qt3d/advancedcustommaterial/CMakeLists.txt
parent5596989f92fd36615e203215ef274bff80bb7e31 (diff)
Add support for building with CMake
Change-Id: If6c887c6356a160a5f3fb906d38a341fff0c7b29 Reviewed-by: Mike Krus <mike.krus@kdab.com>
Diffstat (limited to 'examples/qt3d/advancedcustommaterial/CMakeLists.txt')
-rw-r--r--examples/qt3d/advancedcustommaterial/CMakeLists.txt87
1 files changed, 87 insertions, 0 deletions
diff --git a/examples/qt3d/advancedcustommaterial/CMakeLists.txt b/examples/qt3d/advancedcustommaterial/CMakeLists.txt
new file mode 100644
index 000000000..40f6f2ad3
--- /dev/null
+++ b/examples/qt3d/advancedcustommaterial/CMakeLists.txt
@@ -0,0 +1,87 @@
+# Generated from advancedcustommaterial.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(advancedcustommaterial LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Qml)
+find_package(Qt6 COMPONENTS Quick)
+
+add_qt_gui_executable(advancedcustommaterial
+ main.cpp
+)
+target_link_libraries(advancedcustommaterial PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+
+# Resources:
+set(qml_resource_files
+ "SceneRoot.qml"
+ "Water.qml"
+ "WaterMaterial.qml"
+ "main.qml"
+)
+
+qt6_add_resources(advancedcustommaterial "qml"
+ PREFIX
+ "/"
+ FILES
+ ${qml_resource_files}
+)
+set(models_resource_files
+ "models/waterPlane.obj"
+)
+
+qt6_add_resources(advancedcustommaterial "models"
+ PREFIX
+ "/"
+ FILES
+ ${models_resource_files}
+)
+set(textures_resource_files
+ "textures/WaterDiffuse.jpg"
+ "textures/WaterNormal.jpg"
+ "textures/WaterSpecular.jpg"
+ "textures/Waterwave.jpg"
+ "textures/foam.jpg"
+ "textures/sky.jpg"
+)
+
+qt6_add_resources(advancedcustommaterial "textures"
+ PREFIX
+ "/"
+ FILES
+ ${textures_resource_files}
+)
+set(shaders_resource_files
+ "shaders/es2/water.frag"
+ "shaders/es2/water.vert"
+ "shaders/gl3/water.frag"
+ "shaders/gl3/water.vert"
+)
+
+qt6_add_resources(advancedcustommaterial "shaders"
+ PREFIX
+ "/"
+ FILES
+ ${shaders_resource_files}
+)
+
+install(TARGETS advancedcustommaterial
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)