summaryrefslogtreecommitdiffstats
path: root/examples/qt3d/controls/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-10-16 16:10:16 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-10-16 16:49:27 +0200
commitc4be23758f05719584f2bc4c676fda81c57a9d63 (patch)
treef9f17dbc41663639fffbf163633fb263126fa6ee /examples/qt3d/controls/CMakeLists.txt
parent26ec84b4b123991ae4351d974fcbc753ee1d833e (diff)
CMake: Regenerate qt3d examples
Many of the examples were missing find_package() calls. Some were missing some example install dir things. Some missing special cases. Some incorrectly specified library names due to missing mappings in pro2cmake. Some incorrectly specified target names. Change-Id: I131a02dc679502ea6c1cdeb32962e77f09e672af Reviewed-by: Mike Krus <mike.krus@kdab.com>
Diffstat (limited to 'examples/qt3d/controls/CMakeLists.txt')
-rw-r--r--examples/qt3d/controls/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/examples/qt3d/controls/CMakeLists.txt b/examples/qt3d/controls/CMakeLists.txt
index 962d62813..61c7b0e8f 100644
--- a/examples/qt3d/controls/CMakeLists.txt
+++ b/examples/qt3d/controls/CMakeLists.txt
@@ -44,7 +44,10 @@ qt6_add_resources(controls "controls"
FILES
${controls_resource_files}
)
+
+# special case begin
target_sources(controls PRIVATE ${controls_resources_files}) # just to show qml files in creator
+# special case end
install(TARGETS controls
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"