summaryrefslogtreecommitdiffstats
path: root/examples/qt3d/scene2d/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-10-16 16:10:16 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-10-16 16:49:27 +0200
commitc4be23758f05719584f2bc4c676fda81c57a9d63 (patch)
treef9f17dbc41663639fffbf163633fb263126fa6ee /examples/qt3d/scene2d/CMakeLists.txt
parent26ec84b4b123991ae4351d974fcbc753ee1d833e (diff)
CMake: Regenerate qt3d examples
Many of the examples were missing find_package() calls. Some were missing some example install dir things. Some missing special cases. Some incorrectly specified library names due to missing mappings in pro2cmake. Some incorrectly specified target names. Change-Id: I131a02dc679502ea6c1cdeb32962e77f09e672af Reviewed-by: Mike Krus <mike.krus@kdab.com>
Diffstat (limited to 'examples/qt3d/scene2d/CMakeLists.txt')
-rw-r--r--examples/qt3d/scene2d/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/examples/qt3d/scene2d/CMakeLists.txt b/examples/qt3d/scene2d/CMakeLists.txt
index b5273ac5b..b64eb4de2 100644
--- a/examples/qt3d/scene2d/CMakeLists.txt
+++ b/examples/qt3d/scene2d/CMakeLists.txt
@@ -19,11 +19,13 @@ find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Qml)
find_package(Qt6 COMPONENTS Quick)
+find_package(Qt6 COMPONENTS 3DQuick)
+find_package(Qt6 COMPONENTS 3DQuickExtras)
-add_qt_gui_executable(scene2dsample
+add_qt_gui_executable(scene2dsample # special case
main.cpp
)
-target_link_libraries(scene2dsample PUBLIC
+target_link_libraries(scene2dsample PUBLIC # special case
Qt::3DQuick
Qt::3DQuickExtras
Qt::Core
@@ -40,14 +42,14 @@ set(scene2d_resource_files
"main.qml"
)
-qt6_add_resources(scene2dsample "scene2d"
+qt6_add_resources(scene2dsample "scene2d" # special case
PREFIX
"/"
FILES
${scene2d_resource_files}
)
-install(TARGETS scene2dsample
+install(TARGETS scene2dsample # special case
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"