summaryrefslogtreecommitdiffstats
path: root/examples/qt3d/simple-qml/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-10-16 16:10:16 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-10-16 16:49:27 +0200
commitc4be23758f05719584f2bc4c676fda81c57a9d63 (patch)
treef9f17dbc41663639fffbf163633fb263126fa6ee /examples/qt3d/simple-qml/CMakeLists.txt
parent26ec84b4b123991ae4351d974fcbc753ee1d833e (diff)
CMake: Regenerate qt3d examples
Many of the examples were missing find_package() calls. Some were missing some example install dir things. Some missing special cases. Some incorrectly specified library names due to missing mappings in pro2cmake. Some incorrectly specified target names. Change-Id: I131a02dc679502ea6c1cdeb32962e77f09e672af Reviewed-by: Mike Krus <mike.krus@kdab.com>
Diffstat (limited to 'examples/qt3d/simple-qml/CMakeLists.txt')
-rw-r--r--examples/qt3d/simple-qml/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/examples/qt3d/simple-qml/CMakeLists.txt b/examples/qt3d/simple-qml/CMakeLists.txt
index cd9bf9fd6..ec8c63114 100644
--- a/examples/qt3d/simple-qml/CMakeLists.txt
+++ b/examples/qt3d/simple-qml/CMakeLists.txt
@@ -17,8 +17,14 @@ set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}")
find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS 3DCore)
+find_package(Qt6 COMPONENTS 3DRender)
+find_package(Qt6 COMPONENTS 3DInput)
+find_package(Qt6 COMPONENTS 3DQuick)
+find_package(Qt6 COMPONENTS 3DLogic)
find_package(Qt6 COMPONENTS Qml)
find_package(Qt6 COMPONENTS Quick)
+find_package(Qt6 COMPONENTS 3DQuickExtras)
add_qt_gui_executable(simple-qml
main.cpp
@@ -26,7 +32,7 @@ add_qt_gui_executable(simple-qml
target_link_libraries(simple-qml PUBLIC
Qt::3DCore
Qt::3DInput
- 3DLogic
+ Qt::3DLogic
Qt::3DQuick
Qt::3DQuickExtras
Qt::3DRender
@@ -49,7 +55,9 @@ qt6_add_resources(simple-qml "simple-qml"
${simple-qml_resource_files}
)
+# special case begin
target_sources(simple-qml PRIVATE ${simple-qml_resource_files})
+# special case end
install(TARGETS simple-qml
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"