summaryrefslogtreecommitdiffstats
path: root/src/quick3d/imports/render/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Krus <mike.krus@kdab.com>2020-05-08 14:06:53 +0100
committerMike Krus <mike.krus@kdab.com>2020-05-22 08:53:50 +0100
commit22dd30949938083aceda8267c41c920c61c0d388 (patch)
treea49704414a853624006b860d1a92689bc4f5ca88 /src/quick3d/imports/render/CMakeLists.txt
parent5596989f92fd36615e203215ef274bff80bb7e31 (diff)
Add support for building with CMake
Change-Id: If6c887c6356a160a5f3fb906d38a341fff0c7b29 Reviewed-by: Mike Krus <mike.krus@kdab.com>
Diffstat (limited to 'src/quick3d/imports/render/CMakeLists.txt')
-rw-r--r--src/quick3d/imports/render/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/quick3d/imports/render/CMakeLists.txt b/src/quick3d/imports/render/CMakeLists.txt
new file mode 100644
index 000000000..34b688e41
--- /dev/null
+++ b/src/quick3d/imports/render/CMakeLists.txt
@@ -0,0 +1,32 @@
+# Generated from importsrender.pro.
+
+#####################################################################
+## quick3drenderplugin:
+#####################################################################
+
+qt_add_qml_module(quick3drenderplugin
+ URI "Qt3D.Render"
+ VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME Qt3DQuick3DRenderPlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ qt3dquick3drenderplugin.cpp qt3dquick3drenderplugin.h
+ PUBLIC_LIBRARIES
+ Qt::3DCore
+ Qt::3DQuick
+ Qt::3DQuickPrivate
+ Qt::3DQuickRenderPrivate
+ Qt::3DRender
+ Qt::3DRenderPrivate
+ Qt::Core
+ Qt::CorePrivate
+ Qt::Gui
+ Qt::Qml
+ Qt::QmlPrivate
+)
+
+#### Keys ignored in scope 1:.:.:importsrender.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
+# OTHER_FILES = "qmldir"
+# TARGETPATH = "Qt3D/Render"