summaryrefslogtreecommitdiffstats
path: root/tests/auto/render/attribute/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Krus <mike.krus@kdab.com>2020-05-08 14:06:53 +0100
committerMike Krus <mike.krus@kdab.com>2020-05-22 08:53:50 +0100
commit22dd30949938083aceda8267c41c920c61c0d388 (patch)
treea49704414a853624006b860d1a92689bc4f5ca88 /tests/auto/render/attribute/CMakeLists.txt
parent5596989f92fd36615e203215ef274bff80bb7e31 (diff)
Add support for building with CMake
Change-Id: If6c887c6356a160a5f3fb906d38a341fff0c7b29 Reviewed-by: Mike Krus <mike.krus@kdab.com>
Diffstat (limited to 'tests/auto/render/attribute/CMakeLists.txt')
-rw-r--r--tests/auto/render/attribute/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/tests/auto/render/attribute/CMakeLists.txt b/tests/auto/render/attribute/CMakeLists.txt
new file mode 100644
index 000000000..09c679bae
--- /dev/null
+++ b/tests/auto/render/attribute/CMakeLists.txt
@@ -0,0 +1,38 @@
+# Generated from attribute.pro.
+
+#####################################################################
+## tst_attribute Test:
+#####################################################################
+
+qt_add_test(tst_attribute
+ SOURCES
+ ../commons/testrenderer.cpp ../commons/testrenderer.h
+ tst_attribute.cpp
+ INCLUDE_DIRECTORIES
+ ../../core/common
+ ../commons
+ PUBLIC_LIBRARIES
+ Qt::3DCore
+ Qt::3DCorePrivate
+ Qt::3DRender
+ Qt::3DRenderPrivate
+ Qt::CorePrivate
+ Qt::Gui
+)
+
+#### Keys ignored in scope 1:.:.:attribute.pro:<TRUE>:
+# TEMPLATE = "app"
+
+## Scopes:
+#####################################################################
+
+qt_extend_target(tst_attribute CONDITION QT_FEATURE_private_tests
+ SOURCES
+ ../../core/common/qbackendnodetester.cpp ../../core/common/qbackendnodetester.h
+ ../../core/common/testarbiter.h
+)
+
+qt_extend_target(tst_attribute CONDITION useCommonTestAspect
+ SOURCES
+ ../commons/testaspect.cpp ../commons/testaspect.h
+)