summaryrefslogtreecommitdiffstats
path: root/tests/auto/render/qproximityfilter/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Krus <mike.krus@kdab.com>2020-06-19 17:45:57 +0100
committerMike Krus <mike.krus@kdab.com>2020-06-24 21:51:28 +0100
commit8448855b8050e5682387d97585c7211b5cf8c7aa (patch)
treed786e03b1f0a18ff9d2a8aa2487408d19944bd2b /tests/auto/render/qproximityfilter/CMakeLists.txt
parent8e84a1caee42da4b0613db17a9851240a96497aa (diff)
Add missing tests and benchmarks
Many got missed by script it seems. Cleaned all those in render to use the shared cmake config script. Also added benchmark build, in release only (not tried to run them). Change-Id: I63bbdddedd50a51ea5ac585419527b461380d9cc Reviewed-by: Paul Lemire <paul.lemire@kdab.com>
Diffstat (limited to 'tests/auto/render/qproximityfilter/CMakeLists.txt')
-rw-r--r--tests/auto/render/qproximityfilter/CMakeLists.txt16
1 files changed, 2 insertions, 14 deletions
diff --git a/tests/auto/render/qproximityfilter/CMakeLists.txt b/tests/auto/render/qproximityfilter/CMakeLists.txt
index c477edf57..8e221c6bb 100644
--- a/tests/auto/render/qproximityfilter/CMakeLists.txt
+++ b/tests/auto/render/qproximityfilter/CMakeLists.txt
@@ -6,11 +6,7 @@
qt_add_test(tst_qproximityfilter
SOURCES
- ../commons/testrenderer.cpp ../commons/testrenderer.h
tst_qproximityfilter.cpp
- INCLUDE_DIRECTORIES
- ../../core/common
- ../commons
PUBLIC_LIBRARIES
Qt::3DCore
Qt::3DCorePrivate
@@ -26,13 +22,5 @@ qt_add_test(tst_qproximityfilter
## Scopes:
#####################################################################
-qt_extend_target(tst_qproximityfilter CONDITION QT_FEATURE_private_tests
- SOURCES
- ../../core/common/qbackendnodetester.cpp ../../core/common/qbackendnodetester.h
- ../../core/common/testarbiter.h
-)
-
-qt_extend_target(tst_qproximityfilter CONDITION useCommonTestAspect
- SOURCES
- ../commons/testaspect.cpp ../commons/testaspect.h
-)
+include(../commons/commons.cmake)
+qt3d_setup_common_render_test(tst_qproximityfilter)