summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 68c198072..36ed2165b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,13 +13,17 @@ project(Qt3D # special case
# special case begin
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
- Concurrent Widgets Qml Quick Gamepad OpenGL Multimedia)
+ Network Concurrent Widgets Qml Quick Gamepad OpenGL Multimedia)
# special case end
if(NOT TARGET Qt::Gui)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")
return()
endif()
+if(NOT TARGET Qt::Network)
+ message(NOTICE "Skipping the build as the condition \"TARGET Qt::Network\" is not met.")
+ return()
+endif()
if(WASM OR NOT QT_FEATURE_opengl)
message(NOTICE "Skipping the build as the condition \"QT_FEATURE_opengl AND NOT WASM\" is not met.")
return()