summaryrefslogtreecommitdiffstats
path: root/examples/qt3d/basicshapes-cpp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qt3d/basicshapes-cpp/CMakeLists.txt')
-rw-r--r--examples/qt3d/basicshapes-cpp/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/examples/qt3d/basicshapes-cpp/CMakeLists.txt b/examples/qt3d/basicshapes-cpp/CMakeLists.txt
new file mode 100644
index 000000000..cebb87ae7
--- /dev/null
+++ b/examples/qt3d/basicshapes-cpp/CMakeLists.txt
@@ -0,0 +1,36 @@
+# Generated from basicshapes-cpp.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(basicshapes-cpp LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Widgets)
+
+add_qt_gui_executable(basicshapes-cpp
+ main.cpp
+ scenemodifier.cpp scenemodifier.h
+)
+target_link_libraries(basicshapes-cpp PUBLIC
+ Qt::3DCore
+ Qt::3DExtras
+ Qt::3DInput
+ Qt::3DRender
+ Qt::Core
+ Qt::Gui
+ Qt::Widgets
+)
+
+install(TARGETS basicshapes-cpp
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)