summaryrefslogtreecommitdiffstats
path: root/examples/qt3d/scene2d/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qt3d/scene2d/CMakeLists.txt')
-rw-r--r--examples/qt3d/scene2d/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/qt3d/scene2d/CMakeLists.txt b/examples/qt3d/scene2d/CMakeLists.txt
index 5fae98613..28c12c159 100644
--- a/examples/qt3d/scene2d/CMakeLists.txt
+++ b/examples/qt3d/scene2d/CMakeLists.txt
@@ -25,6 +25,10 @@ find_package(Qt6 COMPONENTS 3DQuickExtras)
qt_add_executable(scene2dsample # special case
main.cpp
)
+set_target_properties(scene2dsample PROPERTIES # special case
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
target_link_libraries(scene2dsample PUBLIC # special case
Qt::3DQuick
Qt::3DQuickExtras