summaryrefslogtreecommitdiffstats
path: root/examples/qt3d/scene3d/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qt3d/scene3d/CMakeLists.txt')
-rw-r--r--examples/qt3d/scene3d/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/qt3d/scene3d/CMakeLists.txt b/examples/qt3d/scene3d/CMakeLists.txt
index 605e903a5..e1243ca44 100644
--- a/examples/qt3d/scene3d/CMakeLists.txt
+++ b/examples/qt3d/scene3d/CMakeLists.txt
@@ -19,6 +19,7 @@ find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Qml)
find_package(Qt6 COMPONENTS Quick)
+find_package(Qt6 COMPONENTS 3DInput)
add_qt_gui_executable(scene3d
main.cpp
@@ -44,7 +45,10 @@ qt6_add_resources(scene3d "scene3d"
FILES
${scene3d_resource_files}
)
+
+# special case begin
target_sources(scene3d PRIVATE ${scene3d_resource_files})
+# special case end
install(TARGETS scene3d
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"