summaryrefslogtreecommitdiffstats
path: root/src/render/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/render/CMakeLists.txt')
-rw-r--r--src/render/CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/render/CMakeLists.txt b/src/render/CMakeLists.txt
index 32e1a4bd2..cc5012671 100644
--- a/src/render/CMakeLists.txt
+++ b/src/render/CMakeLists.txt
@@ -311,10 +311,16 @@ qt_internal_add_module(3DRender
Qt::Concurrent
Qt::CorePrivate
Qt::3DCorePrivate
-)
-# QTransform conflicts
-set_target_properties(3DRender PROPERTIES UNITY_BUILD OFF)
+ NO_UNITY_BUILD_SOURCES
+ # name clashes with internal linkage
+ backend/pointsvisitor.cpp
+ backend/segmentsvisitor.cpp
+ framegraph/frustumculling.cpp
+ jobs/frustumcullingjob.cpp
+ io/qsceneimportfactory.cpp
+ io/qsceneexportfactory.cpp
+)
# Resources:
set(materialsystem_resource_files