summaryrefslogtreecommitdiffstats
path: root/tests/auto/core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/core/CMakeLists.txt')
-rw-r--r--tests/auto/core/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/auto/core/CMakeLists.txt b/tests/auto/core/CMakeLists.txt
index b5e65e8ff..5971ba67d 100644
--- a/tests/auto/core/CMakeLists.txt
+++ b/tests/auto/core/CMakeLists.txt
@@ -1,7 +1,11 @@
# Generated from core.pro.
add_subdirectory(handle)
-add_subdirectory(qresourcemanager)
+if(NOT (UNIX AND NOT APPLE AND NOT WIN32 AND CMAKE_CROSSCOMPILING))
+ # that test is flacky on QEMU (crashes on app exit QTBUG-107693),
+ # so disabling when cross-compiling on linux
+ add_subdirectory(qresourcemanager)
+endif()
add_subdirectory(nodes)
add_subdirectory(qaspectengine)
add_subdirectory(qaspectfactory)