summaryrefslogtreecommitdiffstats
path: root/tests/auto/input/utils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/input/utils/CMakeLists.txt')
-rw-r--r--tests/auto/input/utils/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/auto/input/utils/CMakeLists.txt b/tests/auto/input/utils/CMakeLists.txt
new file mode 100644
index 000000000..1c7d2f77d
--- /dev/null
+++ b/tests/auto/input/utils/CMakeLists.txt
@@ -0,0 +1,34 @@
+# Generated from utils.pro.
+
+#####################################################################
+## tst_utils Test:
+#####################################################################
+
+qt_add_test(tst_utils
+ SOURCES
+ ../commons/testdevice.h
+ ../commons/testdeviceproxy.h
+ tst_utils.cpp
+ INCLUDE_DIRECTORIES
+ ../../core/common
+ ../commons
+ PUBLIC_LIBRARIES
+ Qt::3DCore
+ Qt::3DCorePrivate
+ Qt::3DInput
+ Qt::3DInputPrivate
+ Qt::CorePrivate
+ Qt::Gui
+)
+
+#### Keys ignored in scope 1:.:.:utils.pro:<TRUE>:
+# TEMPLATE = "app"
+
+## Scopes:
+#####################################################################
+
+qt_extend_target(tst_utils CONDITION QT_FEATURE_private_tests
+ SOURCES
+ ../../core/common/qbackendnodetester.cpp ../../core/common/qbackendnodetester.h
+ ../../core/common/testarbiter.h
+)