summaryrefslogtreecommitdiffstats
path: root/tests/auto/quick3d/3dinput/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/quick3d/3dinput/CMakeLists.txt')
-rw-r--r--tests/auto/quick3d/3dinput/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/tests/auto/quick3d/3dinput/CMakeLists.txt b/tests/auto/quick3d/3dinput/CMakeLists.txt
new file mode 100644
index 000000000..52612a899
--- /dev/null
+++ b/tests/auto/quick3d/3dinput/CMakeLists.txt
@@ -0,0 +1,38 @@
+# Generated from 3dinput.pro.
+
+#####################################################################
+## tst_import3dinput Test:
+#####################################################################
+
+qt_add_test(tst_import3dinput
+ SOURCES
+ ../../render/qmlscenereader/qmlscenereader.cpp ../../render/qmlscenereader/qmlscenereader.h
+ tst_import3dinput.cpp
+ INCLUDE_DIRECTORIES
+ ../../render/qmlscenereader
+ PUBLIC_LIBRARIES
+ Qt::3DCore
+ Qt::3DCorePrivate
+ Qt::3DQuick
+ Qt::3DRender
+ Qt::3DRenderPrivate
+ Qt::CorePrivate
+ Qt::Gui
+ Qt::Qml
+)
+
+# Resources:
+set(3dinput_resource_files
+ "3dinput.qml"
+)
+
+qt_add_resource(tst_import3dinput "3dinput"
+ PREFIX
+ "/"
+ FILES
+ ${3dinput_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:3dinput.pro:<TRUE>:
+# TEMPLATE = "app"