summaryrefslogtreecommitdiffstats
path: root/tests/auto/render/gltfplugins/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/render/gltfplugins/CMakeLists.txt')
-rw-r--r--tests/auto/render/gltfplugins/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/tests/auto/render/gltfplugins/CMakeLists.txt b/tests/auto/render/gltfplugins/CMakeLists.txt
new file mode 100644
index 000000000..fbb6fddec
--- /dev/null
+++ b/tests/auto/render/gltfplugins/CMakeLists.txt
@@ -0,0 +1,40 @@
+# Generated from gltfplugins.pro.
+
+#####################################################################
+## tst_gltfplugins Test:
+#####################################################################
+
+qt_add_test(tst_gltfplugins
+ SOURCES
+ tst_gltfplugins.cpp
+ PUBLIC_LIBRARIES
+ Qt::3DCore
+ Qt::3DCorePrivate
+ Qt::3DExtras
+ Qt::3DRender
+ Qt::3DRenderPrivate
+ Qt::Gui
+)
+
+# Resources:
+set(images_resource_files
+ "ontopmaterial.frag"
+ "ontopmaterial.vert"
+ "ontopmaterialES2.frag"
+ "ontopmaterialES2.vert"
+ "qtlogo.png"
+ "qtlogo_normal.png"
+ "qtlogo_specular.png"
+ "qtlogo_with_alpha.png"
+)
+
+qt_add_resource(tst_gltfplugins "images"
+ PREFIX
+ "/"
+ FILES
+ ${images_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:gltfplugins.pro:<TRUE>:
+# TEMPLATE = "app"