summaryrefslogtreecommitdiffstats
path: root/tests/auto/render/qrendertargetoutput/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/render/qrendertargetoutput/CMakeLists.txt')
-rw-r--r--tests/auto/render/qrendertargetoutput/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/tests/auto/render/qrendertargetoutput/CMakeLists.txt b/tests/auto/render/qrendertargetoutput/CMakeLists.txt
new file mode 100644
index 000000000..296edcd3c
--- /dev/null
+++ b/tests/auto/render/qrendertargetoutput/CMakeLists.txt
@@ -0,0 +1,38 @@
+# Generated from qrendertargetoutput.pro.
+
+#####################################################################
+## tst_qrendertargetoutput Test:
+#####################################################################
+
+qt_add_test(tst_qrendertargetoutput
+ SOURCES
+ ../commons/testrenderer.cpp ../commons/testrenderer.h
+ tst_qrendertargetoutput.cpp
+ INCLUDE_DIRECTORIES
+ ../../core/common
+ ../commons
+ PUBLIC_LIBRARIES
+ Qt::3DCore
+ Qt::3DCorePrivate
+ Qt::3DRender
+ Qt::3DRenderPrivate
+ Qt::CorePrivate
+ Qt::Gui
+)
+
+#### Keys ignored in scope 1:.:.:qrendertargetoutput.pro:<TRUE>:
+# TEMPLATE = "app"
+
+## Scopes:
+#####################################################################
+
+qt_extend_target(tst_qrendertargetoutput CONDITION QT_FEATURE_private_tests
+ SOURCES
+ ../../core/common/qbackendnodetester.cpp ../../core/common/qbackendnodetester.h
+ ../../core/common/testarbiter.h
+)
+
+qt_extend_target(tst_qrendertargetoutput CONDITION useCommonTestAspect
+ SOURCES
+ ../commons/testaspect.cpp ../commons/testaspect.h
+)