summaryrefslogtreecommitdiffstats
path: root/tests/auto/render/scene2d/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/render/scene2d/CMakeLists.txt')
-rw-r--r--tests/auto/render/scene2d/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/tests/auto/render/scene2d/CMakeLists.txt b/tests/auto/render/scene2d/CMakeLists.txt
new file mode 100644
index 000000000..ad7d357d3
--- /dev/null
+++ b/tests/auto/render/scene2d/CMakeLists.txt
@@ -0,0 +1,40 @@
+# Generated from scene2d.pro.
+
+#####################################################################
+## tst_scene2d Test:
+#####################################################################
+
+qt_add_test(tst_scene2d
+ SOURCES
+ ../commons/testrenderer.cpp ../commons/testrenderer.h
+ tst_scene2d.cpp
+ INCLUDE_DIRECTORIES
+ ../../core/common
+ ../commons
+ PUBLIC_LIBRARIES
+ Qt::3DCore
+ Qt::3DCorePrivate
+ Qt::3DQuickScene2D
+ Qt::3DQuickScene2DPrivate
+ Qt::3DRender
+ Qt::3DRenderPrivate
+ Qt::CorePrivate
+ Qt::Gui
+)
+
+#### Keys ignored in scope 1:.:.:scene2d.pro:<TRUE>:
+# TEMPLATE = "app"
+
+## Scopes:
+#####################################################################
+
+qt_extend_target(tst_scene2d CONDITION QT_FEATURE_private_tests
+ SOURCES
+ ../../core/common/qbackendnodetester.cpp ../../core/common/qbackendnodetester.h
+ ../../core/common/testarbiter.h
+)
+
+qt_extend_target(tst_scene2d CONDITION useCommonTestAspect
+ SOURCES
+ ../commons/testaspect.cpp ../commons/testaspect.h
+)