summaryrefslogtreecommitdiffstats
path: root/tests/manual/compute-manual/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/compute-manual/CMakeLists.txt')
-rw-r--r--tests/manual/compute-manual/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/tests/manual/compute-manual/CMakeLists.txt b/tests/manual/compute-manual/CMakeLists.txt
new file mode 100644
index 000000000..4b30aef71
--- /dev/null
+++ b/tests/manual/compute-manual/CMakeLists.txt
@@ -0,0 +1,41 @@
+# Generated from compute-manual.pro.
+
+#####################################################################
+## compute-manual Binary:
+#####################################################################
+
+qt_add_manual_test(compute-manual
+ GUI
+ SOURCES
+ main.cpp
+ PUBLIC_LIBRARIES
+ Qt::3DCore
+ Qt::3DInput
+ Qt::3DQuick
+ Qt::3DRender
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+# Resources:
+set(compute-manual_resource_files
+ "ComputeFrameGraph.qml"
+ "ComputeMaterial.qml"
+ "ParticlesScene.qml"
+ "main.qml"
+ "particles.comp"
+ "particles.frag"
+ "particles.vert"
+)
+
+qt_add_resource(compute-manual "compute-manual"
+ PREFIX
+ "/"
+ FILES
+ ${compute-manual_resource_files}
+)
+
+
+## Scopes:
+#####################################################################