summaryrefslogtreecommitdiffstats
path: root/tests/manual/tessellation-modes/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/tessellation-modes/CMakeLists.txt')
-rw-r--r--tests/manual/tessellation-modes/CMakeLists.txt54
1 files changed, 54 insertions, 0 deletions
diff --git a/tests/manual/tessellation-modes/CMakeLists.txt b/tests/manual/tessellation-modes/CMakeLists.txt
new file mode 100644
index 000000000..637e60037
--- /dev/null
+++ b/tests/manual/tessellation-modes/CMakeLists.txt
@@ -0,0 +1,54 @@
+# Generated from tessellation-modes.pro.
+
+#####################################################################
+## tessellation-modes Binary:
+#####################################################################
+
+qt_add_manual_test(tessellation-modes
+ GUI
+ SOURCES
+ main.cpp
+ tessellatedquadmesh.cpp tessellatedquadmesh.h
+ PUBLIC_LIBRARIES
+ Qt::3DCore
+ Qt::3DInput
+ Qt::3DQuick
+ Qt::3DQuickExtras
+ Qt::3DRender
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+# Resources:
+set(tessellation-modes_resource_files
+ "BasicCamera.qml"
+ "TessellatedQuad.qml"
+ "TessellatedWireframeEffect.qml"
+ "TessellatedWireframeMaterial.qml"
+ "main.qml"
+ "shaders/flat.frag"
+ "shaders/isolines.tcs"
+ "shaders/isolines.tes"
+ "shaders/passthru.vert"
+ "shaders/phongwireframe.frag"
+ "shaders/quads.tcs"
+ "shaders/quads.tes"
+ "shaders/robustwireframe.geom"
+ "shaders/triangles.tcs"
+ "shaders/triangles.tes"
+)
+
+qt_add_resource(tessellation-modes "tessellation-modes"
+ PREFIX
+ "/"
+ FILES
+ ${tessellation-modes_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:tessellation-modes.pro:<TRUE>:
+# OTHER_FILES = "main.qml" "BasicCamera.qml" "TessellatedWireframeEffect.qml" "TessellatedWireframeMaterial.qml" "TessellatedQuad.qml" "shaders/*"
+
+## Scopes:
+#####################################################################