summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoni Jäntti <joni.jantti@qt.io>2018-09-04 12:09:08 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2019-08-11 09:37:41 +0300
commit3b0fbe7213fae9b9e891511d3aecce5183b57e66 (patch)
tree6808fd244afd488d7e9da4a4318c656d19c8fe08
parentfbec569aea2de9da30cb4b3820d35912797e9105 (diff)
Provisioning: Ubuntu 18.04: Add required packages for b2qt
These packages are required for building b2qt module. Needed also on 5.12 branch as meta-qt5 follows Qt branching and will take provisionings from here. Change-Id: Ia6c5ffd95d4f778b23f381a6f1f5473aa11971e3 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io> (cherry picked from commit ee9dd0d8601bbe252a6a99e44a3376016911f1b0) Reviewed-by: Tony Sarajärvi <tony.sarajarvi@qt.io>
-rwxr-xr-xcoin/provisioning/qtci-linux-Ubuntu-18.04-x86_64/02-apt.sh5
1 files changed, 5 insertions, 0 deletions
diff --git a/coin/provisioning/qtci-linux-Ubuntu-18.04-x86_64/02-apt.sh b/coin/provisioning/qtci-linux-Ubuntu-18.04-x86_64/02-apt.sh
index d6c04d5b..c85c989d 100755
--- a/coin/provisioning/qtci-linux-Ubuntu-18.04-x86_64/02-apt.sh
+++ b/coin/provisioning/qtci-linux-Ubuntu-18.04-x86_64/02-apt.sh
@@ -159,6 +159,11 @@ installPackages+=(dkms)
installPackages+=(libspeechd-dev)
#Pypdf for PDF reading in RTA tests
installPackages+=(python-pypdf2)
+# Needed for b2qt
+installPackages+=(git-lfs)
+installPackages+=(chrpath)
+installPackages+=(gawk)
+installPackages+=(texinfo)
echo "Running update for apt"
waitLoop