summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Hausmann <simon.hausmann@qt.io>2017-07-25 16:42:44 +0200
committerSimon Hausmann <simon.hausmann@qt.io>2017-08-04 19:22:40 +0000
commit49ccf716dca2a14d21ce6869cdcd64b861c53834 (patch)
treebbb8216570669927bcb0c3f99a7f77d53ab4c422
parentd1d36cbbf181cd9d5f63950265db23d39a6375f5 (diff)
Remove unused provisioning scripts
RHEL 7.2, Ubuntu 15.04, 16.04 and OpenSuSE 42.1 are not used in the Qt 5.6 branch. Let's remove the scripts to avoid confusion. Change-Id: I3829ea320ad77ebd25c9cf5bebfeed89f37f44dc Reviewed-by: Simo Fält <simo.falt@qt.io> Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@qt.io>
-rw-r--r--coin/provisioning/qtci-linux-RHEL-7.2-x86_64/08-pythondev.sh5
-rw-r--r--coin/provisioning/qtci-linux-RHEL-7.2-x86_64/09-cmake.sh53
-rw-r--r--coin/provisioning/qtci-linux-Ubuntu-15.04-x86_64/001-suppress-shutdown-indicator.sh4
-rw-r--r--coin/provisioning/qtci-linux-Ubuntu-16.04-x86_64/001-suppress-shutdown-indicator.sh4
-rw-r--r--coin/provisioning/qtci-linux-Ubuntu-16.04-x86_64/003-apt-update.sh2
-rw-r--r--coin/provisioning/qtci-linux-Ubuntu-16.04-x86_64/006-qt-build-dependencies.sh46
-rw-r--r--coin/provisioning/qtci-linux-openSUSE-42.1-x86_64/09-cmake.sh53
7 files changed, 0 insertions, 167 deletions
diff --git a/coin/provisioning/qtci-linux-RHEL-7.2-x86_64/08-pythondev.sh b/coin/provisioning/qtci-linux-RHEL-7.2-x86_64/08-pythondev.sh
deleted file mode 100644
index ad1bf18f..00000000
--- a/coin/provisioning/qtci-linux-RHEL-7.2-x86_64/08-pythondev.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-# provides: python development libraries
-# version: provided by default Linux distribution repository
-# needed to build pyside
-sudo subscription-manager refresh
-sudo yum install -y python-devel python-virtualenv
diff --git a/coin/provisioning/qtci-linux-RHEL-7.2-x86_64/09-cmake.sh b/coin/provisioning/qtci-linux-RHEL-7.2-x86_64/09-cmake.sh
deleted file mode 100644
index dd35e01d..00000000
--- a/coin/provisioning/qtci-linux-RHEL-7.2-x86_64/09-cmake.sh
+++ /dev/null
@@ -1,53 +0,0 @@
-#!/bin/bash
-
-#############################################################################
-##
-## Copyright (C) 2016 The Qt Company Ltd.
-## Contact: http://www.qt.io/licensing/
-##
-## This file is part of the test suite of the Qt Toolkit.
-##
-## $QT_BEGIN_LICENSE:LGPL21$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see http://www.qt.io/terms-conditions. For further
-## information use the contact form at http://www.qt.io/contact-us.
-##
-## GNU Lesser General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU Lesser
-## General Public License version 2.1 or version 3 as published by the Free
-## Software Foundation and appearing in the file LICENSE.LGPLv21 and
-## LICENSE.LGPLv3 included in the packaging of this file. Please review the
-## following information to ensure the GNU Lesser General Public License
-## requirements will be met: https://www.gnu.org/licenses/lgpl.html and
-## http://www.gnu.org/licenses/old-licenses/lgpl-2.1.html.
-##
-## As a special exception, The Qt Company gives you certain additional
-## rights. These rights are described in The Qt Company LGPL Exception
-## version 1.1, included in the file LGPL_EXCEPTION.txt in this package.
-##
-## $QT_END_LICENSE$
-##
-#############################################################################
-
-# This script installs CMake 3.6.2
-
-# CMake is needed for autotests that verify that Qt can be built with CMake
-
-# shellcheck source=../common/InstallFromCompressedFileFromURL.sh
-source "${BASH_SOURCE%/*}/../common/InstallFromCompressedFileFromURL.sh"
-
-version="3.6.2"
-PrimaryUrl="http://ci-files01-hki.ci.local/input/cmake/cmake-3.6.2-Linux-x86_64.tar.gz"
-AltUrl="https://cmake.org/files/v3.6/cmake-3.6.2-Linux-x86_64.tar.gz"
-SHA1="dd9d8d57b66109d4bac6eef9209beb94608a185c"
-targetFolder="/opt/cmake-$version"
-appPrefix="cmake-$version-Linux-x86_64"
-
-InstallFromCompressedFileFromURL "$PrimaryUrl" "$AltUrl" "$SHA1" "$targetFolder" "$appPrefix"
-
-echo "Adding $targetFolder/bin to PATH"
-echo "export PATH=$targetFolder/bin:$PATH" >> ~/.bashrc
diff --git a/coin/provisioning/qtci-linux-Ubuntu-15.04-x86_64/001-suppress-shutdown-indicator.sh b/coin/provisioning/qtci-linux-Ubuntu-15.04-x86_64/001-suppress-shutdown-indicator.sh
deleted file mode 100644
index f11263b7..00000000
--- a/coin/provisioning/qtci-linux-Ubuntu-15.04-x86_64/001-suppress-shutdown-indicator.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/usr/bin/env sh
-
-# Disable questions on shutdown.
-gsettings set com.canonical.indicator.session suppress-logout-restart-shutdown true
diff --git a/coin/provisioning/qtci-linux-Ubuntu-16.04-x86_64/001-suppress-shutdown-indicator.sh b/coin/provisioning/qtci-linux-Ubuntu-16.04-x86_64/001-suppress-shutdown-indicator.sh
deleted file mode 100644
index f11263b7..00000000
--- a/coin/provisioning/qtci-linux-Ubuntu-16.04-x86_64/001-suppress-shutdown-indicator.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/usr/bin/env sh
-
-# Disable questions on shutdown.
-gsettings set com.canonical.indicator.session suppress-logout-restart-shutdown true
diff --git a/coin/provisioning/qtci-linux-Ubuntu-16.04-x86_64/003-apt-update.sh b/coin/provisioning/qtci-linux-Ubuntu-16.04-x86_64/003-apt-update.sh
deleted file mode 100644
index 2f7e2e47..00000000
--- a/coin/provisioning/qtci-linux-Ubuntu-16.04-x86_64/003-apt-update.sh
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/usr/bin/env bash
-sudo apt-get update
diff --git a/coin/provisioning/qtci-linux-Ubuntu-16.04-x86_64/006-qt-build-dependencies.sh b/coin/provisioning/qtci-linux-Ubuntu-16.04-x86_64/006-qt-build-dependencies.sh
deleted file mode 100644
index 30a6caad..00000000
--- a/coin/provisioning/qtci-linux-Ubuntu-16.04-x86_64/006-qt-build-dependencies.sh
+++ /dev/null
@@ -1,46 +0,0 @@
-#!/usr/bin/env bash
-
-#############################################################################
-##
-## Copyright (C) 2016 The Qt Company Ltd.
-## Contact: http://www.qt.io/licensing/
-##
-## This file is part of the test suite of the Qt Toolkit.
-##
-## $QT_BEGIN_LICENSE:LGPL21$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see http://www.qt.io/terms-conditions. For further
-## information use the contact form at http://www.qt.io/contact-us.
-##
-## GNU Lesser General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU Lesser
-## General Public License version 2.1 or version 3 as published by the Free
-## Software Foundation and appearing in the file LICENSE.LGPLv21 and
-## LICENSE.LGPLv3 included in the packaging of this file. Please review the
-## following information to ensure the GNU Lesser General Public License
-## requirements will be met: https://www.gnu.org/licenses/lgpl.html and
-## http://www.gnu.org/licenses/old-licenses/lgpl-2.1.html.
-##
-## As a special exception, The Qt Company gives you certain additional
-## rights. These rights are described in The Qt Company LGPL Exception
-## version 1.1, included in the file LGPL_EXCEPTION.txt in this package.
-##
-## $QT_END_LICENSE$
-##
-#############################################################################
-
-sudo apt-get -y build-dep qt5-default
-
-# qtbase
-sudo apt-get -y install "^libxcb.*" libx11-xcb-dev libglu1-mesa-dev libxrender-dev libxi-dev
-sudo apt-get -y install libxcb-xinerama0-dev libdbus-1-dev libatspi2.0-dev
-
-# qtmultimedia
-sudo apt-get -y install libasound2-dev libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev
-
-# qtwebengine
-sudo apt-get -y install libssl-dev libxcursor-dev libxcomposite-dev libxdamage-dev libxrandr-dev libfontconfig1-dev libcap-dev libxtst-dev libpulse-dev libudev-dev libpci-dev libnss3-dev libasound2-dev libxss-dev libegl1-mesa-dev gperf bison
diff --git a/coin/provisioning/qtci-linux-openSUSE-42.1-x86_64/09-cmake.sh b/coin/provisioning/qtci-linux-openSUSE-42.1-x86_64/09-cmake.sh
deleted file mode 100644
index dd35e01d..00000000
--- a/coin/provisioning/qtci-linux-openSUSE-42.1-x86_64/09-cmake.sh
+++ /dev/null
@@ -1,53 +0,0 @@
-#!/bin/bash
-
-#############################################################################
-##
-## Copyright (C) 2016 The Qt Company Ltd.
-## Contact: http://www.qt.io/licensing/
-##
-## This file is part of the test suite of the Qt Toolkit.
-##
-## $QT_BEGIN_LICENSE:LGPL21$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see http://www.qt.io/terms-conditions. For further
-## information use the contact form at http://www.qt.io/contact-us.
-##
-## GNU Lesser General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU Lesser
-## General Public License version 2.1 or version 3 as published by the Free
-## Software Foundation and appearing in the file LICENSE.LGPLv21 and
-## LICENSE.LGPLv3 included in the packaging of this file. Please review the
-## following information to ensure the GNU Lesser General Public License
-## requirements will be met: https://www.gnu.org/licenses/lgpl.html and
-## http://www.gnu.org/licenses/old-licenses/lgpl-2.1.html.
-##
-## As a special exception, The Qt Company gives you certain additional
-## rights. These rights are described in The Qt Company LGPL Exception
-## version 1.1, included in the file LGPL_EXCEPTION.txt in this package.
-##
-## $QT_END_LICENSE$
-##
-#############################################################################
-
-# This script installs CMake 3.6.2
-
-# CMake is needed for autotests that verify that Qt can be built with CMake
-
-# shellcheck source=../common/InstallFromCompressedFileFromURL.sh
-source "${BASH_SOURCE%/*}/../common/InstallFromCompressedFileFromURL.sh"
-
-version="3.6.2"
-PrimaryUrl="http://ci-files01-hki.ci.local/input/cmake/cmake-3.6.2-Linux-x86_64.tar.gz"
-AltUrl="https://cmake.org/files/v3.6/cmake-3.6.2-Linux-x86_64.tar.gz"
-SHA1="dd9d8d57b66109d4bac6eef9209beb94608a185c"
-targetFolder="/opt/cmake-$version"
-appPrefix="cmake-$version-Linux-x86_64"
-
-InstallFromCompressedFileFromURL "$PrimaryUrl" "$AltUrl" "$SHA1" "$targetFolder" "$appPrefix"
-
-echo "Adding $targetFolder/bin to PATH"
-echo "export PATH=$targetFolder/bin:$PATH" >> ~/.bashrc