aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-04-15 12:45:41 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2021-04-15 13:27:10 +0200
commit002b6f075c09cfb5507007a9bfe620195a859f08 (patch)
tree148e2969edcc908701ffe1372bfb6f466c56f15d /CMakeLists.txt
parentcfd78386157411a321c495aa276a8575675f35e2 (diff)
CMake: Use qtbase's version as the top-level project version
This avoids the need to bump the qt5.git project version when branching the next minor Qt version. Pick-to: 6.1 6.0 Task-number: QTBUG-92861 Change-Id: Ib20ab614caefece00bd9e0172d9269077239ba6a Reviewed-by: Alexey Edelev <alexey.edelev@qt.io> Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 13bad03d..6baa7067 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,7 @@ cmake_minimum_required(VERSION ${__qt_minimum_cmake_version})
include("${__qt6_qtbase_src_path}/cmake/QtAutoDetect.cmake")
project(Qt
- VERSION 6.1.0
+ VERSION "${QT_REPO_MODULE_VERSION}"
DESCRIPTION "Qt Libraries"
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C ASM