aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2020-11-19 12:19:39 +0100
committerAlexey Edelev <alexey.edelev@qt.io>2020-11-19 12:57:58 +0100
commit0393017610a23bfb64ce469f71e98d30795137e2 (patch)
treec9d567413c55f09749b6b08a7e75b476e625cc78 /CMakeLists.txt
parent85e32ebcb4e518b067aee261934fe0cfebfea29d (diff)
CMake: Fix fuzzer-no-link check for super builds
Add platform detection before report enties evaluation in root CMakeLists.txt. QtPlatformSupport.cmake defines required platform-specific variables line CLANG before qt_configure_eval_commands call. Fixes: QTBUG-88496 Change-Id: I13afdbe29f2bffeb2c36c17e231b98b2aa2b41e6 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Andreas Buhr <andreas.buhr@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 92970aa9..8ebf5608 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -83,6 +83,7 @@ endforeach()
if(NOT QT_BUILD_STANDALONE_TESTS)
# Display a summary of everything
include(QtBuildInformation)
+ include(QtPlatformSupport)
qt_print_feature_summary()
qt_print_build_instructions()
endif()