aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2021-04-13 11:31:50 +0200
committerTor Arne Vestbø <tor.arne.vestbo@qt.io>2021-04-13 14:19:04 +0200
commit4a9d291ca69af37e51406759521ab08a6e647589 (patch)
tree68ca5fd0a8d9528d052a982411e36dbc98c6ced0 /CMakeLists.txt
parent027f8ccb080c856c248af0e43f797c4461fd16f0 (diff)
Cache list of submodules
Otherwise running cmake with QT_BUILD_SUBMODULES set in the environment would not persist for later cmake runs without the environment set, resulting in trying to reconfigure with every single available module. Change-Id: I85e57b16fdc8e51cae8fff083c7a7536b0ed16f1 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8e894cb2..13bad03d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,6 +45,7 @@ if(NOT QT_BUILD_SUBMODULES)
qt_internal_find_modules(QT_BUILD_SUBMODULES)
endif()
endif()
+set(QT_BUILD_SUBMODULES "${QT_BUILD_SUBMODULES}" CACHE STRING "Submodules to build")
set(qt_module_dependency_map_prefix "__qt_module_dependencies_")
qt_internal_sort_module_dependencies("${QT_BUILD_SUBMODULES}" QT_BUILD_SUBMODULES