aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Edmundson <davidedmundson@kde.org>2020-08-12 12:39:08 +0100
committerDavid Edmundson <davidedmundson@kde.org>2020-09-10 09:54:47 +0100
commitc416b79407009248a8eaa327c11cb8d1e39414f2 (patch)
tree540629d8ca6823b66fd9b6f14b0880b449841238 /CMakeLists.txt
parent572aadf1fbdeed2dff306da633389ffb5b4ff5dc (diff)
Cmake: Include 3rdparty cmake dependencies in CMAKE_MODULE_PATH
QtWayland looks for WaylandScanner. If QtBase is installed our CMake find files will be installed and everything will work correctly. If QtBase is not installed yet or out of date, we need to add our source cmake files to the search path. We currently add one of the 3rd party directories, but not the subdirectories. Change-Id: I53ce26b5b21b7e5e74752c730bca90295147f851 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 01fca842..6e5d2a26 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,6 +41,8 @@ endfunction()
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
if (NOT QT_BUILD_STANDALONE_TESTS)
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/qtbase/cmake")
+ list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/qtbase/cmake/3rdparty/extra-cmake-modules/find-modules")
+ list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/qtbase/cmake/3rdparty/kwin")
endif()
include(ECMOptionalAddSubdirectory)