aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2020-11-16 12:35:31 +0100
committerAlexey Edelev <semlanik@gmail.com>2020-11-16 12:56:01 +0100
commitc7c8d1e06402d5b04a2e50642c088d4e538b6d55 (patch)
treeebdc2a93104265e45a0f7980f221583767b0b6f9 /CMakeLists.txt
parentb34fa5f9cffd88ad3b73b9406ab21b6f419b40ff (diff)
CMake: Check module dependency before configure
Move all modules dependency check before actual configuration of any module. Change-Id: I40838ab59de1be1cd8ca3a006e195455f2692982 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 77fc641b..92970aa9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,10 +47,9 @@ qt_internal_sort_module_dependencies("${BUILD_SUBMODULES}" BUILD_SUBMODULES
"${qt_module_dependency_map_prefix}")
foreach(module IN LISTS BUILD_SUBMODULES)
- message(NOTICE "Configuring '${module}'")
-
# Check for unmet dependencies
if(NOT DEFINED BUILD_${module} OR BUILD_${module})
+ message(NOTICE "Check dependencies of '${module}'")
foreach(dep IN LISTS "${qt_module_dependency_map_prefix}${module}")
if (dep STREQUAL "qtbase")
# Always available skip
@@ -67,7 +66,10 @@ foreach(module IN LISTS BUILD_SUBMODULES)
endif()
endforeach()
endif()
+endforeach()
+foreach(module IN LISTS BUILD_SUBMODULES)
+ message(NOTICE "Configuring '${module}'")
ecm_optional_add_subdirectory("${module}")
if(module STREQUAL "qtbase")