aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2022-06-13 11:25:34 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2022-06-16 10:59:03 +0000
commit0e15878f08c2be1a20dbf6bab85b61f61541f845 (patch)
tree13340a0d438cfa72e24d87a42e6486f30ce651b2 /CMakeLists.txt
parenta856a1f90b9b41c0312c851d98353ea07f13d821 (diff)
CMake: Take custom libdir into account
When configuring with -libdir set to something that is not recognized by CMake's find_package search procedure, top-level builds failed to configure. This was due to a hard-coded lib/cmake directory added to CMAKE_PREFIX_PATH. Fixes: QTBUG-103823 Change-Id: If8b48e35e654089f32cbe4af9936238cd82b3dbb Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> (cherry picked from commit 96be84d703fb6b0c9ab95040b53c3b78b7a06ce7) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 88e440a2..70d67220 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -98,7 +98,7 @@ foreach(module IN LISTS QT_BUILD_SUBMODULES)
if(module STREQUAL "qtbase")
if (NOT QT_BUILD_STANDALONE_TESTS)
- list(APPEND CMAKE_PREFIX_PATH "${QtBase_BINARY_DIR}/lib/cmake")
+ list(APPEND CMAKE_PREFIX_PATH "${QtBase_BINARY_DIR}/${INSTALL_LIBDIR}/cmake")
list(APPEND CMAKE_FIND_ROOT_PATH "${QtBase_BINARY_DIR}")
endif()
endif()