aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-04-15 12:45:41 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-04-15 21:22:26 +0000
commit2b9697ed7f6a116754554537ebc713f57f6c248d (patch)
tree713dccb405e805e56bc7c3c6516b07e37e13750a /CMakeLists.txt
parent0ed49f89a5cb0278794eb026a54e6a9785800b1e (diff)
CMake: Use qtbase's version as the top-level project version
This avoids the need to bump the qt5.git project version when branching the next minor Qt version. Task-number: QTBUG-92861 Change-Id: Ib20ab614caefece00bd9e0172d9269077239ba6a Reviewed-by: Alexey Edelev <alexey.edelev@qt.io> Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io> (cherry picked from commit 002b6f075c09cfb5507007a9bfe620195a859f08) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 547865a9..5fe9a6ca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,7 @@ cmake_minimum_required(VERSION ${__qt_minimum_cmake_version})
include("${__qt6_qtbase_src_path}/cmake/QtAutoDetect.cmake")
project(Qt
- VERSION 6.1.0
+ VERSION "${QT_REPO_MODULE_VERSION}"
DESCRIPTION "Qt Libraries"
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C ASM