aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2020-10-09 11:50:41 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2020-10-12 18:28:10 +0200
commiteaf64a222fcdcf54e2593914f5a60be3b6a18931 (patch)
tree275e12ba2a9f7797f124cd5e6d99dc18d16107f5 /CMakeLists.txt
parent70dc8438fce5c9a5b6c9ea9392dbbadf92ea2cb1 (diff)
CMake: Run auto-detection routines before any project command
This is needed to ensure that the auto-detection runs before any toolchain file is loaded, like in a stand-alone qtbase build. This fixes the issue that we had to specify ANDROID_STL=c++_shared in a top-level build, even though it's properly defaulted in QtAutoDetect.cmake. Task-number: QTBUG-87309 Change-Id: I8ced2213ca2e5a877bfd210e59da4ef4d6c8ac74 Reviewed-by: Cristian Adam <cristian.adam@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 13817e75..18eba9de 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,7 @@
cmake_minimum_required(VERSION 3.15.0)
+include(${CMAKE_CURRENT_SOURCE_DIR}/qtbase/cmake/QtAutoDetect.cmake)
+
project(Qt
VERSION 6.0.0
DESCRIPTION "Qt Libraries"