summaryrefslogtreecommitdiffstats
path: root/coin/platform_configs/qt5.yaml
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-12-18 15:38:01 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-02-03 14:15:33 +0100
commit25e007372082105c198d686d3130e22aaf9dc7fd (patch)
treea20ced461f7cd779f5d96ff7813476803d619f24 /coin/platform_configs/qt5.yaml
parent486139715b2e5f45e69b324740cec0b0b3f2dfe7 (diff)
Use legacy instructions when building all qmake configurations
This change is preparation for merging qtbase wip/cmake -> dev, because that will bring in the new yaml instructions on how to build the CMake configurations, which means that legacy instructions provided by Coin itself need to be used for all the existing qmake configurations. Change-Id: I7005835719b83b7186138292a2e1baf4d2a4a3e0 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'coin/platform_configs/qt5.yaml')
-rw-r--r--coin/platform_configs/qt5.yaml10
1 files changed, 5 insertions, 5 deletions
diff --git a/coin/platform_configs/qt5.yaml b/coin/platform_configs/qt5.yaml
index 19eb1732..c98a351a 100644
--- a/coin/platform_configs/qt5.yaml
+++ b/coin/platform_configs/qt5.yaml
@@ -1,12 +1,12 @@
-
Template: 'qtci-windows-7-x86-3'
Compiler: 'Mingw73'
- Features: ['Packaging', 'DisableTests']
+ Features: ['Packaging', 'DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -release -force-debug-info -separate-debug-info -nomake tests -nomake examples -opengl dynamic -openssl -I %OPENSSL_INCLUDE_x86% -L %OPENSSL_LIB_x86% -no-sql-mysql -plugin-sql-sqlite -plugin-sql-odbc -I %MYSQL_INCLUDE_x86% -L %MYSQL_LIB_x86% -plugin-sql-psql -I %POSTGRESQL_INCLUDE_x86% -L %POSTGRESQL_LIB_x86% -platform win32-g++'
-
Template: 'qtci-windows-10-x86_64-15'
Compiler: 'Mingw73'
- Features: ['Packaging', 'DisableTests']
+ Features: ['Packaging', 'DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -release -force-debug-info -separate-debug-info -nomake tests -nomake examples -opengl dynamic -openssl -I %OPENSSL_INCLUDE_x64% -L %OPENSSL_LIB_x64% -no-sql-mysql -plugin-sql-sqlite -plugin-sql-odbc -I %MYSQL_INCLUDE_x64% -L %MYSQL_LIB_x64% -plugin-sql-psql -I %POSTGRESQL_INCLUDE_x64% -L %POSTGRESQL_LIB_x64% -platform win32-g++'
-
Template: 'qtci-windows-10-x86_64-15'
@@ -14,7 +14,7 @@
Target arch: 'multi'
Compiler: 'Mingw73'
Target compiler: 'Clang'
- Features: ['Packaging', 'DisableTests']
+ Features: ['Packaging', 'DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix c:\Users\qt\work\install -release -nomake tests -nomake examples -no-sql-mysql -no-dbus -opengl es2 -sysconfdir /etc/xdg -openssl -I c:\utils\openssl-android-master\include -xplatform android-clang -android-sdk C:\Utils\Android -android-ndk c:\Utils\Android\android-ndk-r20'
-
Template: 'qtci-macos-10.14-x86_64'
@@ -22,11 +22,11 @@
Target arch: 'multi'
Compiler: 'Clang'
Target compiler: 'Clang'
- Features: ['Packaging', 'DisableTests']
+ Features: ['Packaging', 'DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /Users/qt/work/install -release -nomake tests -nomake examples -no-sql-mysql -no-dbus -no-qpa-platform-guard -opengl es2 -sysconfdir /etc/xdg -openssl -I /usr/local/opt/openssl/include -xplatform android-clang -android-sdk /opt/android/sdk -android-ndk /opt/android/android-ndk-r20 -android-ndk-host darwin-x86_64'
-
Template: 'qtci-macos-10.14-x86_64'
Target os: 'WebAssembly'
Compiler: 'Clang'
- Features: ['Packaging', 'DisableTests']
+ Features: ['Packaging', 'DisableTests', 'UseLegacyInstructions']
Configure arguments: '-opensource -confirm-license -verbose -prefix /Users/qt/work/install -release -nomake examples -nomake tests -no-feature-thread -static -no-dbus -no-headersclean -no-ssl -no-warnings-are-errors -no-pch -xplatform wasm-emscripten'