aboutsummaryrefslogtreecommitdiffstats
path: root/coin/provisioning/qtci-linux-SLES-15-x86_64/02-zypperpackages.sh
diff options
context:
space:
mode:
authorHeikki Halmet <heikki.halmet@qt.io>2020-12-23 11:36:21 +0200
committerHeikki Halmet <heikki.halmet@qt.io>2021-01-04 06:14:37 +0000
commit88c2d05f5d4706bb16ff4146b4979f2c8608140e (patch)
treea039b915514b7b459a644dc498fa8e9419c900e1 /coin/provisioning/qtci-linux-SLES-15-x86_64/02-zypperpackages.sh
parent6cafc374865cf051cdda62b21323cd1e375f64ef (diff)
Provisioning: Install Nodejs version 10 for QtWebengine
Task-number: QTQAINFRA-4057 Change-Id: I6f476db59ee8fdb13d37a22fdd878c3db1fd1594 Reviewed-by: Tony Sarajärvi <tony.sarajarvi@qt.io>
Diffstat (limited to 'coin/provisioning/qtci-linux-SLES-15-x86_64/02-zypperpackages.sh')
-rwxr-xr-xcoin/provisioning/qtci-linux-SLES-15-x86_64/02-zypperpackages.sh5
1 files changed, 4 insertions, 1 deletions
diff --git a/coin/provisioning/qtci-linux-SLES-15-x86_64/02-zypperpackages.sh b/coin/provisioning/qtci-linux-SLES-15-x86_64/02-zypperpackages.sh
index a366e807..bed165f1 100755
--- a/coin/provisioning/qtci-linux-SLES-15-x86_64/02-zypperpackages.sh
+++ b/coin/provisioning/qtci-linux-SLES-15-x86_64/02-zypperpackages.sh
@@ -109,6 +109,9 @@ sudo zypper -nq install java
# open-vm-tools requires update. Version in tier1 is broken and causes segfault on boot.
sudo zypper -nq update open-vm-tools
+# Nodejs - needed by QtWebEngine
+sudo zypper -nq install nodejs10
+sudo zypper -nq install nodejs10-devel
+
gccVersion="$(gcc --version |grep gcc |cut -b 17-23)"
echo "GCC = $gccVersion" >> versions.txt
-