summaryrefslogtreecommitdiffstats
path: root/coin
diff options
context:
space:
mode:
authorHeikki Halmet <heikki.halmet@qt.io>2020-01-30 13:24:53 +0200
committerTony Sarajärvi <tony.sarajarvi@qt.io>2020-02-15 09:03:00 +0000
commitfdb88edba04d175b1eadd8d6142e5e8132d414f8 (patch)
tree8c62bdb8fe560a7de5bc84b56b29b71a65083af8 /coin
parentd757c6d0ece7823a28c8601a56f567580aa8cf16 (diff)
Provisioning: Make sure that Perl's Data:Dumper is installed
Data:dumper is critical for release script build.pl. Currently data:dumper is installed by devtoolset as a dependency for autoconf. But, it seems, that in earlier version of devtoolset the autoconf wasn't installed by devtoolset which caused the failure with build.pl. Change-Id: I487a17ca0eb37c5984eb2f195e1024ed019b80d2 Reviewed-by: Tony Sarajärvi <tony.sarajarvi@qt.io>
Diffstat (limited to 'coin')
-rwxr-xr-xcoin/provisioning/qtci-linux-RHEL-7.6-x86_64/04-install-packages.sh2
1 files changed, 2 insertions, 0 deletions
diff --git a/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/04-install-packages.sh b/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/04-install-packages.sh
index d3dcc420..b3ecceea 100755
--- a/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/04-install-packages.sh
+++ b/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/04-install-packages.sh
@@ -120,6 +120,8 @@ installPackages+=(xz-devel)
installPackages+=(zlib-devel)
installPackages+=(libffi-devel)
installPackages+=(libsqlite3x-devel)
+# Build.pl
+installPackages+=(perl-Data-Dumper)
sudo yum -y install "${installPackages[@]}"