summaryrefslogtreecommitdiffstats
path: root/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/04-install-packages.sh
diff options
context:
space:
mode:
Diffstat (limited to 'coin/provisioning/qtci-linux-RHEL-7.6-x86_64/04-install-packages.sh')
-rwxr-xr-xcoin/provisioning/qtci-linux-RHEL-7.6-x86_64/04-install-packages.sh12
1 files changed, 11 insertions, 1 deletions
diff --git a/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/04-install-packages.sh b/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/04-install-packages.sh
index b956d6a3..6b569552 100755
--- a/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/04-install-packages.sh
+++ b/coin/provisioning/qtci-linux-RHEL-7.6-x86_64/04-install-packages.sh
@@ -38,13 +38,20 @@ set -ex
# Remove update notifications and packagekit running in the background
sudo yum -y remove PackageKit gnome-software
+sudo yum-config-manager --enable rhel-server-rhscl-7-rpms
+
installPackages=()
-installPackages+=(git)
+installPackages+=(rh-git29)
installPackages+=(zlib-devel)
installPackages+=(glib2-devel)
installPackages+=(openssl-devel)
installPackages+=(freetype-devel)
installPackages+=(fontconfig-devel)
+# cmake build
+installPackages+=(ninja-build)
+installPackages+=(pcre2-devel)
+installPackages+=(double-conversion-devel)
+installPackages+=(zstd)
# EGL support
installPackages+=(mesa-libEGL-devel)
installPackages+=(mesa-libGL-devel)
@@ -118,6 +125,9 @@ installPackages+=(vulkan-devel)
sudo yum -y install "${installPackages[@]}"
+scl enable rh-git29 bash
+sudo ln -s /opt/rh/rh-git29/root/usr/bin/git /usr/local/bin/git
+
sudo ln -s /opt/rh/rh-python36/root/usr/bin/python3 /usr/local/bin/python3
sudo ln -s /opt/rh/rh-python36/root/usr/bin/pip3 /usr/local/bin/pip3
# We shouldn't use yum to install virtualenv. The one found from package repo is not