summaryrefslogtreecommitdiffstats
path: root/coin/provisioning
diff options
context:
space:
mode:
Diffstat (limited to 'coin/provisioning')
-rw-r--r--coin/provisioning/common/InstallAppFromCompressedFileFromURL.sh7
-rw-r--r--coin/provisioning/common/InstallPKGFromURL.sh3
-rw-r--r--coin/provisioning/common/cmake.ps155
-rwxr-xr-xcoin/provisioning/common/cmake.sh2
-rwxr-xr-xcoin/provisioning/common/cmake_linux.sh53
-rw-r--r--coin/provisioning/common/install-ruby.ps13
-rw-r--r--coin/provisioning/common/python.ps14
-rw-r--r--coin/provisioning/qtci-linux-RHEL-6.6-x86_64/09-cmake.sh54
-rw-r--r--coin/provisioning/qtci-linux-RHEL-7.2-x86_64/08-pythondev.sh5
-rw-r--r--coin/provisioning/qtci-linux-RHEL-7.2-x86_64/09-cmake.sh1
-rwxr-xr-xcoin/provisioning/qtci-linux-Ubuntu-16.04-x86_64/002-apt.sh38
-rwxr-xr-xcoin/provisioning/qtci-linux-openSUSE-42.3-x86_64/001-systemsetup.sh13
-rwxr-xr-xcoin/provisioning/qtci-linux-openSUSE-42.3-x86_64/002-zypperpackages.sh46
-rwxr-xr-xcoin/provisioning/qtci-linux-openSUSE-42.3-x86_64/008-pythondev.sh8
-rwxr-xr-xcoin/provisioning/qtci-linux-openSUSE-42.3-x86_64/009-cmake.sh1
-rwxr-xr-xcoin/provisioning/qtci-linux-openSUSE-42.3-x86_64/08-libclang.sh (renamed from coin/provisioning/qtci-linux-openSUSE-42.1-x86_64/08-libclang.sh)0
-rwxr-xr-xcoin/provisioning/qtci-macos-10.12-x86_64/025-cmake.sh53
-rwxr-xr-xcoin/provisioning/qtci-macos-10.12-x86_64/035-openssl.sh4
18 files changed, 218 insertions, 132 deletions
diff --git a/coin/provisioning/common/InstallAppFromCompressedFileFromURL.sh b/coin/provisioning/common/InstallAppFromCompressedFileFromURL.sh
index b6072062..bee16dd2 100644
--- a/coin/provisioning/common/InstallAppFromCompressedFileFromURL.sh
+++ b/coin/provisioning/common/InstallAppFromCompressedFileFromURL.sh
@@ -74,7 +74,12 @@ function InstallAppFromCompressedFileFromURL {
echo "Extension for file: $extension"
echo "Creating temporary file and directory"
targetFile=$(mktemp "$TMPDIR$(uuidgen).$extension") || throw $ExceptionCreateTmpFile
- targetDirectory=$(mktemp -d) || throw $ExceptionCreateTmpDirectory
+ # macOS 10.10 mktemp does require prefix
+ if [[ $OSTYPE == "darwin14" ]]; then
+ targetDirectory=$(mktemp -d -t '10.10') || throw $ExceptionCreateTmpDirectory
+ else
+ targetDirectory=$(mktemp -d) || throw $ExceptionCreateTmpDirectory
+ fi
DownloadURL "$url" "$url_alt" "$expectedSha1" "$targetFile"
echo "Uncompress $targetFile"
case $extension in
diff --git a/coin/provisioning/common/InstallPKGFromURL.sh b/coin/provisioning/common/InstallPKGFromURL.sh
index bd916cec..c00b646c 100644
--- a/coin/provisioning/common/InstallPKGFromURL.sh
+++ b/coin/provisioning/common/InstallPKGFromURL.sh
@@ -69,7 +69,8 @@ function InstallPKGFromURL {
esac
}
echo "Checking SHA1 on PKG '$targetFile'"
- echo "$expectedSha1 *$targetFile" | /usr/bin/shasum --check || throw $ExceptionSHA1
+ echo "$expectedSha1 *$targetFile" > $targetFile.sha1
+ /usr/bin/shasum --check $targetFile.sha1 || throw $ExceptionSHA1
echo "Run installer on PKG"
sudo installer -package "$targetFile" -target "$targetDirectory" || throw $ExceptionInstallerPKG
echo "Removing file '$targetFile'"
diff --git a/coin/provisioning/common/cmake.ps1 b/coin/provisioning/common/cmake.ps1
index 197eec57..50e2e82c 100644
--- a/coin/provisioning/common/cmake.ps1
+++ b/coin/provisioning/common/cmake.ps1
@@ -1,10 +1,57 @@
+#############################################################################
+##
+## Copyright (C) 2017 The Qt Company Ltd.
+## Contact: http://www.qt.io/licensing/
+##
+## This file is part of the provisioning scripts of the Qt Toolkit.
+##
+## $QT_BEGIN_LICENSE:LGPL21$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see http://www.qt.io/terms-conditions. For further
+## information use the contact form at http://www.qt.io/contact-us.
+##
+## GNU Lesser General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU Lesser
+## General Public License version 2.1 or version 3 as published by the Free
+## Software Foundation and appearing in the file LICENSE.LGPLv21 and
+## LICENSE.LGPLv3 included in the packaging of this file. Please review the
+## following information to ensure the GNU Lesser General Public License
+## requirements will be met: https://www.gnu.org/licenses/lgpl.html and
+## http://www.gnu.org/licenses/old-licenses/lgpl-2.1.html.
+##
+## As a special exception, The Qt Company gives you certain additional
+## rights. These rights are described in The Qt Company LGPL Exception
+## version 1.1, included in the file LGPL_EXCEPTION.txt in this package.
+##
+## $QT_END_LICENSE$
+##
+#############################################################################
+
. "$PSScriptRoot\helpers.ps1"
-$zip = "c:\users\qt\downloads\cmake-3.6.2-win32-x86.zip"
+$majorminorversion = "3.6"
+$version = "3.6.2"
+
+$zip = "c:\users\qt\downloads\cmake-" + $version + "-win32-x86.zip"
+$officialurl = "https://cmake.org/files/v" + $majorminorversion + "/cmake-" + $version + "-win32-x86.zip"
+$cachedurl = "\\ci-files01-hki.intra.qt.io\provisioning\cmake\cmake-" + $version + "-win32-x86.zip"
-Download https://cmake.org/files/v3.6/cmake-3.6.2-win32-x86.zip \\ci-files01-hki.intra.qt.io\provisioning\cmake\cmake-3.6.2-win32-x86.zip $zip
+Download $officialurl $cachedurl $zip
Verify-Checksum $zip "541F6E7EFD228E46770B8631FFE57097576E4D4E"
Extract-Zip $zip C:
-Remove-Item C:\CMake -Force -Recurse
-Rename-Item C:\cmake-3.6.2-win32-x86 C:\CMake
+# TODO: Remove line below after all Windows TIER2 VMs are based on vanilla OS
+if((Test-Path -Path "C:\CMake" )){
+ try {
+ Rename-Item -ErrorAction 'Stop' "C:\CMake" C:\CMake_old
+ } catch {}
+}
+$defaultinstallfolder = "C:\cmake-" + $version + "-win32-x86"
+Rename-Item $defaultinstallfolder C:\CMake
+
+echo "CMake = $version" >> ~\versions.txt
+
diff --git a/coin/provisioning/common/cmake.sh b/coin/provisioning/common/cmake.sh
index fe84cd0e..e10dd41d 100755
--- a/coin/provisioning/common/cmake.sh
+++ b/coin/provisioning/common/cmake.sh
@@ -47,5 +47,5 @@ appPrefix="cmake-3.6.2-Darwin-x86_64"
InstallAppFromCompressedFileFromURL "$PrimaryUrl" "$AltUrl" "$SHA1" "$appPrefix"
-echo "export PATH=/Applications/CMake.app/Contents/bin:$PATH" >> ~/.bashrc
+echo "export PATH=/Applications/CMake.app/Contents/bin:\$PATH" >> ~/.bashrc
echo "CMake = 3.6.2" >> ~/versions.txt
diff --git a/coin/provisioning/common/cmake_linux.sh b/coin/provisioning/common/cmake_linux.sh
new file mode 100755
index 00000000..c23cf9b2
--- /dev/null
+++ b/coin/provisioning/common/cmake_linux.sh
@@ -0,0 +1,53 @@
+#!/bin/bash
+
+#############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: http://www.qt.io/licensing/
+##
+## This file is part of the test suite of the Qt Toolkit.
+##
+## $QT_BEGIN_LICENSE:LGPL21$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see http://www.qt.io/terms-conditions. For further
+## information use the contact form at http://www.qt.io/contact-us.
+##
+## GNU Lesser General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU Lesser
+## General Public License version 2.1 or version 3 as published by the Free
+## Software Foundation and appearing in the file LICENSE.LGPLv21 and
+## LICENSE.LGPLv3 included in the packaging of this file. Please review the
+## following information to ensure the GNU Lesser General Public License
+## requirements will be met: https://www.gnu.org/licenses/lgpl.html and
+## http://www.gnu.org/licenses/old-licenses/lgpl-2.1.html.
+##
+## As a special exception, The Qt Company gives you certain additional
+## rights. These rights are described in The Qt Company LGPL Exception
+## version 1.1, included in the file LGPL_EXCEPTION.txt in this package.
+##
+## $QT_END_LICENSE$
+##
+#############################################################################
+
+# This script installs CMake 3.6.2
+
+# CMake is needed for autotests that verify that Qt can be built with CMake
+
+# shellcheck source=../common/InstallFromCompressedFileFromURL.sh
+source "${BASH_SOURCE%/*}/../common/InstallFromCompressedFileFromURL.sh"
+
+version="3.6.2"
+PrimaryUrl="http://ci-files01-hki.intra.qt.io/input/cmake/cmake-3.6.2-Linux-x86_64.tar.gz"
+AltUrl="https://cmake.org/files/v3.6/cmake-3.6.2-Linux-x86_64.tar.gz"
+SHA1="dd9d8d57b66109d4bac6eef9209beb94608a185c"
+targetFolder="/opt/cmake-$version"
+appPrefix="cmake-$version-Linux-x86_64"
+
+InstallFromCompressedFileFromURL "$PrimaryUrl" "$AltUrl" "$SHA1" "$targetFolder" "$appPrefix"
+
+echo "Adding $targetFolder/bin to PATH"
+echo "export PATH=$targetFolder/bin:\$PATH" >> ~/.bashrc
diff --git a/coin/provisioning/common/install-ruby.ps1 b/coin/provisioning/common/install-ruby.ps1
index 332a3a89..be0bc3eb 100644
--- a/coin/provisioning/common/install-ruby.ps1
+++ b/coin/provisioning/common/install-ruby.ps1
@@ -48,4 +48,7 @@ cmd /c "$rubyPackage /silent"
echo "Cleaning $rubyPackage.."
Remove-Item -Recurse -Force "$rubyPackage"
+$oldPath = [System.Environment]::GetEnvironmentVariable('Path', 'Machine')
+[Environment]::SetEnvironmentVariable("Path", $oldPath + ";C:\Ruby22-x64\bin", [EnvironmentVariableTarget]::Machine)
+
echo "Ruby = $version" >> ~\versions.txt
diff --git a/coin/provisioning/common/python.ps1 b/coin/provisioning/common/python.ps1
index 6c88689a..29114456 100644
--- a/coin/provisioning/common/python.ps1
+++ b/coin/provisioning/common/python.ps1
@@ -62,7 +62,9 @@ echo "Chancing allowZip64 value to 'True'..."
(Get-Content C:\Python27\lib\zipfile.py) | ForEach-Object { $_ -replace "allowZip64=False", "allowZip64=True" } | Set-Content C:\Python27\lib\zipfile.py
echo "Remove $package..."
del $package
-[Environment]::SetEnvironmentVariable("Path", $env:Path + ";C:\Python27;C:\Python27\Scripts", [EnvironmentVariableTarget]::Machine)
+
+$oldPath = [System.Environment]::GetEnvironmentVariable('Path', 'Machine')
+[Environment]::SetEnvironmentVariable("Path", $oldPath + ";C:\Python27;C:\Python27\Scripts", [EnvironmentVariableTarget]::Machine)
C:\Python27\python.exe -m ensurepip
# Install python virtual env
diff --git a/coin/provisioning/qtci-linux-RHEL-6.6-x86_64/09-cmake.sh b/coin/provisioning/qtci-linux-RHEL-6.6-x86_64/09-cmake.sh
index 7cdfc25c..d7abd285 100644
--- a/coin/provisioning/qtci-linux-RHEL-6.6-x86_64/09-cmake.sh
+++ b/coin/provisioning/qtci-linux-RHEL-6.6-x86_64/09-cmake.sh
@@ -1,53 +1 @@
-#!/bin/bash
-
-#############################################################################
-##
-## Copyright (C) 2016 The Qt Company Ltd.
-## Contact: http://www.qt.io/licensing/
-##
-## This file is part of the test suite of the Qt Toolkit.
-##
-## $QT_BEGIN_LICENSE:LGPL21$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see http://www.qt.io/terms-conditions. For further
-## information use the contact form at http://www.qt.io/contact-us.
-##
-## GNU Lesser General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU Lesser
-## General Public License version 2.1 or version 3 as published by the Free
-## Software Foundation and appearing in the file LICENSE.LGPLv21 and
-## LICENSE.LGPLv3 included in the packaging of this file. Please review the
-## following information to ensure the GNU Lesser General Public License
-## requirements will be met: https://www.gnu.org/licenses/lgpl.html and
-## http://www.gnu.org/licenses/old-licenses/lgpl-2.1.html.
-##
-## As a special exception, The Qt Company gives you certain additional
-## rights. These rights are described in The Qt Company LGPL Exception
-## version 1.1, included in the file LGPL_EXCEPTION.txt in this package.
-##
-## $QT_END_LICENSE$
-##
-#############################################################################
-
-# This script installs CMake 3.6.2
-
-# CMake is needed for autotests that verify that Qt can be built with CMake
-
-# shellcheck source=../common/InstallFromCompressedFileFromURL.sh
-source "${BASH_SOURCE%/*}/../common/InstallFromCompressedFileFromURL.sh"
-
-version="3.6.2"
-PrimaryUrl="http://ci-files01-hki.intra.qt.io/input/cmake/cmake-3.6.2-Linux-x86_64.tar.gz"
-AltUrl="https://cmake.org/files/v3.6/cmake-3.6.2-Linux-x86_64.tar.gz"
-SHA1="dd9d8d57b66109d4bac6eef9209beb94608a185c"
-targetFolder="/opt/cmake-$version"
-appPrefix="cmake-$version-Linux-x86_64"
-
-InstallFromCompressedFileFromURL "$PrimaryUrl" "$AltUrl" "$SHA1" "$targetFolder" "$appPrefix"
-
-echo "Adding $targetFolder/bin to PATH"
-echo "export PATH=$targetFolder/bin:$PATH" >> ~/.bashrc
+$(dirname $0)/../common/cmake_linux.sh
diff --git a/coin/provisioning/qtci-linux-RHEL-7.2-x86_64/08-pythondev.sh b/coin/provisioning/qtci-linux-RHEL-7.2-x86_64/08-pythondev.sh
new file mode 100644
index 00000000..ad1bf18f
--- /dev/null
+++ b/coin/provisioning/qtci-linux-RHEL-7.2-x86_64/08-pythondev.sh
@@ -0,0 +1,5 @@
+# provides: python development libraries
+# version: provided by default Linux distribution repository
+# needed to build pyside
+sudo subscription-manager refresh
+sudo yum install -y python-devel python-virtualenv
diff --git a/coin/provisioning/qtci-linux-RHEL-7.2-x86_64/09-cmake.sh b/coin/provisioning/qtci-linux-RHEL-7.2-x86_64/09-cmake.sh
new file mode 100644
index 00000000..d7abd285
--- /dev/null
+++ b/coin/provisioning/qtci-linux-RHEL-7.2-x86_64/09-cmake.sh
@@ -0,0 +1 @@
+$(dirname $0)/../common/cmake_linux.sh
diff --git a/coin/provisioning/qtci-linux-Ubuntu-16.04-x86_64/002-apt.sh b/coin/provisioning/qtci-linux-Ubuntu-16.04-x86_64/002-apt.sh
index 5cd9a77d..f07be55a 100755
--- a/coin/provisioning/qtci-linux-Ubuntu-16.04-x86_64/002-apt.sh
+++ b/coin/provisioning/qtci-linux-Ubuntu-16.04-x86_64/002-apt.sh
@@ -46,44 +46,44 @@ try
echo "Disabling auto update"
sudo sed -i 's/APT::Periodic::Update-Package-Lists "1";/APT::Periodic::Update-Package-Lists "0";/' /etc/apt/apt.conf.d/10periodic || throw $ExceptionSED
echo "Running update for apt"
- sudo apt update
+ sudo apt-get update
echo "Installing packages"
# Git is not needed by builds themselves, but is nice to have
# immediately as one starts debugging
- sudo DEBIAN_FRONTEND=noninteractive apt -q -y install git || throw $ExceptionAPT
+ sudo DEBIAN_FRONTEND=noninteractive apt-get -q -y install git || throw $ExceptionAPT
# 7zip is a needed decompressing tool
- sudo DEBIAN_FRONTEND=noninteractive apt -q -y install p7zip || throw $ExceptionAPT
+ sudo DEBIAN_FRONTEND=noninteractive apt-get -q -y install p7zip || throw $ExceptionAPT
# libssl-dev provides headers for OpenSSL
- sudo DEBIAN_FRONTEND=noninteractive apt -q -y install libssl-dev || throw $ExceptionAPT
+ sudo DEBIAN_FRONTEND=noninteractive apt-get -q -y install libssl-dev || throw $ExceptionAPT
# Needed libraries for X11 support accordingly to https://wiki.qt.io/Building_Qt_5_from_Git
- sudo DEBIAN_FRONTEND=noninteractive apt -q -y install "^libxcb.*" libx11-xcb-dev libglu1-mesa-dev libxrender-dev libxi-dev || throw $ExceptionAPT
+ sudo DEBIAN_FRONTEND=noninteractive apt-get -q -y install "^libxcb.*" libx11-xcb-dev libglu1-mesa-dev libxrender-dev libxi-dev || throw $ExceptionAPT
# Enable linking to system dbus
- sudo DEBIAN_FRONTEND=noninteractive apt -q -y install libdbus-1-dev || throw $ExceptionAPT
+ sudo DEBIAN_FRONTEND=noninteractive apt-get -q -y install libdbus-1-dev || throw $ExceptionAPT
# Needed libraries for WebEngine
- sudo DEBIAN_FRONTEND=noninteractive apt -q -y install libudev-dev libegl1-mesa-dev libfontconfig1-dev libxss-dev || throw $ExceptionAPT
+ sudo DEBIAN_FRONTEND=noninteractive apt-get -q -y install libudev-dev libegl1-mesa-dev libfontconfig1-dev libxss-dev || throw $ExceptionAPT
# Common event loop handling
- sudo DEBIAN_FRONTEND=noninteractive apt -q -y install libglib2.0-dev || throw $ExceptionAPT
+ sudo DEBIAN_FRONTEND=noninteractive apt-get -q -y install libglib2.0-dev || throw $ExceptionAPT
# MySQL support
- sudo DEBIAN_FRONTEND=noninteractive apt -q -y install libmysqlclient-dev || throw $ExceptionAPT
+ sudo DEBIAN_FRONTEND=noninteractive apt-get -q -y install libmysqlclient-dev || throw $ExceptionAPT
# PostgreSQL support
- sudo DEBIAN_FRONTEND=noninteractive apt -q -y install libpq-dev || throw $ExceptionAPT
+ sudo DEBIAN_FRONTEND=noninteractive apt-get -q -y install libpq-dev || throw $ExceptionAPT
# SQLite support
- sudo DEBIAN_FRONTEND=noninteractive apt -q -y install libsqlite3-dev || throw $ExceptionAPT
+ sudo DEBIAN_FRONTEND=noninteractive apt-get -q -y install libsqlite3-dev || throw $ExceptionAPT
# ODBC support
- sudo DEBIAN_FRONTEND=noninteractive apt -q -y install unixodbc-dev || throw $ExceptionAPT
+ sudo DEBIAN_FRONTEND=noninteractive apt-get -q -y install unixodbc-dev || throw $ExceptionAPT
# Support for FreeType font engine
- sudo DEBIAN_FRONTEND=noninteractive apt -q -y install libfreetype6-dev || throw $ExceptionAPT
+ sudo DEBIAN_FRONTEND=noninteractive apt-get -q -y install libfreetype6-dev || throw $ExceptionAPT
# Enable the usage of system jpeg libraries
- sudo DEBIAN_FRONTEND=noninteractive apt -q -y install libjpeg-dev || throw $ExceptionAPT
+ sudo DEBIAN_FRONTEND=noninteractive apt-get -q -y install libjpeg-dev || throw $ExceptionAPT
# Enable support for printer driver
- sudo DEBIAN_FRONTEND=noninteractive apt -q -y install libcups2-dev || throw $ExceptionAPT
+ sudo DEBIAN_FRONTEND=noninteractive apt-get -q -y install libcups2-dev || throw $ExceptionAPT
# Install libraries needed for QtMultimedia to be able to support all plugins
- sudo DEBIAN_FRONTEND=noninteractive apt -q -y install libasound2-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev || throw $ExceptionAPT
- sudo DEBIAN_FRONTEND=noninteractive apt -q -y install libgstreamer-plugins-good1.0-dev libgstreamer-plugins-bad1.0-dev || throw $ExceptionAPT
+ sudo DEBIAN_FRONTEND=noninteractive apt-get -q -y install libasound2-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev || throw $ExceptionAPT
+ sudo DEBIAN_FRONTEND=noninteractive apt-get -q -y install libgstreamer-plugins-good1.0-dev libgstreamer-plugins-bad1.0-dev || throw $ExceptionAPT
# Support for cross-building to x86 (needed by WebEngine boot2qt builds)
- sudo DEBIAN_FRONTEND=noninteractive apt -q -y install g++-multilib || throw $ExceptionAPT
+ sudo DEBIAN_FRONTEND=noninteractive apt-get -q -y install g++-multilib || throw $ExceptionAPT
# python3 development package
- sudo DEBIAN_FRONTEND=noninteractive apt -q -y install python3-dev python3-pip python3-virtualenv || throw $ExceptionAPT
+ sudo DEBIAN_FRONTEND=noninteractive apt-get -q -y install python3-dev python3-pip python3-virtualenv || throw $ExceptionAPT
)
catch || {
case $ex_code in
diff --git a/coin/provisioning/qtci-linux-openSUSE-42.3-x86_64/001-systemsetup.sh b/coin/provisioning/qtci-linux-openSUSE-42.3-x86_64/001-systemsetup.sh
new file mode 100755
index 00000000..4b2f2546
--- /dev/null
+++ b/coin/provisioning/qtci-linux-openSUSE-42.3-x86_64/001-systemsetup.sh
@@ -0,0 +1,13 @@
+#!/bin/bash
+set -e
+
+BASEDIR=$(dirname "$0")
+source $BASEDIR/../common/network_test_server_ip.txt
+
+sed -i '$ a\[Daemon\]\nAutolock=false\nLockOnResume=false' ~/.config/kscreenlockerrc
+
+echo "Set Network Test Server address to $network_test_server_ip in /etc/hosts"
+echo "$network_test_server_ip qt-test-server qt-test-server.qt-test-net" | sudo tee -a /etc/hosts
+echo "Set DISPLAY"
+echo 'export DISPLAY=":0"' >> ~/.bashrc
+
diff --git a/coin/provisioning/qtci-linux-openSUSE-42.3-x86_64/002-zypperpackages.sh b/coin/provisioning/qtci-linux-openSUSE-42.3-x86_64/002-zypperpackages.sh
new file mode 100755
index 00000000..1f6b9070
--- /dev/null
+++ b/coin/provisioning/qtci-linux-openSUSE-42.3-x86_64/002-zypperpackages.sh
@@ -0,0 +1,46 @@
+#!/bin/bash
+set -e
+
+sudo zypper -nq install git
+# default compiler, gcc 4.8.5
+sudo zypper -nq install gcc
+sudo zypper -nq install gcc-c++
+
+sudo zypper -nq install bison
+sudo zypper -nq install flex
+sudo zypper -nq install gperf
+
+sudo zypper -nq install zlib-devel
+sudo zypper -nq install libudev-devel
+sudo zypper -nq install glib2-devel
+sudo zypper -nq install libopenssl-devel
+sudo zypper -nq install freetype2-devel
+sudo zypper -nq install fontconfig-devel
+
+# EGL support
+sudo zypper -nq install Mesa-libEGL-devel
+sudo zypper -nq install Mesa-libGL-devel
+
+sudo zypper -nq install libxkbcommon-devel
+
+# Xinput2
+sudo zypper -nq install libXi-devel
+
+# system provided XCB libraries
+sudo zypper -nq install xcb-util-devel
+sudo zypper -nq install xcb-util-image-devel
+sudo zypper -nq install xcb-util-keysyms-devel
+sudo zypper -nq install xcb-util-wm-devel
+sudo zypper -nq install xcb-util-renderutil-devel
+
+# ICU
+sudo zypper -nq install libicu-devel
+sudo zypper -nq install libicu52_1
+
+# qtwebengine
+sudo zypper -nq install alsa-devel
+sudo zypper -nq install dbus-1-devel
+sudo zypper -nq install libXcomposite-devel
+sudo zypper -nq install libXcursor-devel
+sudo zypper -nq install libXrandr-devel
+sudo zypper -nq install libXtst-devel
diff --git a/coin/provisioning/qtci-linux-openSUSE-42.3-x86_64/008-pythondev.sh b/coin/provisioning/qtci-linux-openSUSE-42.3-x86_64/008-pythondev.sh
new file mode 100755
index 00000000..d8874561
--- /dev/null
+++ b/coin/provisioning/qtci-linux-openSUSE-42.3-x86_64/008-pythondev.sh
@@ -0,0 +1,8 @@
+#!/bin/bash
+# provides: python development libraries
+# version: provided by default Linux distribution repository
+# needed to build pyside
+sudo zypper -nq install python-devel python-virtualenv
+
+# install python3
+sudo zypper -nq install python3 python3-pip python3-virtualenv
diff --git a/coin/provisioning/qtci-linux-openSUSE-42.3-x86_64/009-cmake.sh b/coin/provisioning/qtci-linux-openSUSE-42.3-x86_64/009-cmake.sh
new file mode 100755
index 00000000..d7abd285
--- /dev/null
+++ b/coin/provisioning/qtci-linux-openSUSE-42.3-x86_64/009-cmake.sh
@@ -0,0 +1 @@
+$(dirname $0)/../common/cmake_linux.sh
diff --git a/coin/provisioning/qtci-linux-openSUSE-42.1-x86_64/08-libclang.sh b/coin/provisioning/qtci-linux-openSUSE-42.3-x86_64/08-libclang.sh
index abbda212..abbda212 100755
--- a/coin/provisioning/qtci-linux-openSUSE-42.1-x86_64/08-libclang.sh
+++ b/coin/provisioning/qtci-linux-openSUSE-42.3-x86_64/08-libclang.sh
diff --git a/coin/provisioning/qtci-macos-10.12-x86_64/025-cmake.sh b/coin/provisioning/qtci-macos-10.12-x86_64/025-cmake.sh
index de025b55..ddb01d64 100755
--- a/coin/provisioning/qtci-macos-10.12-x86_64/025-cmake.sh
+++ b/coin/provisioning/qtci-macos-10.12-x86_64/025-cmake.sh
@@ -1,51 +1,4 @@
-#!/bin/bash
+#!/usr/bin/env bash
-#############################################################################
-##
-## Copyright (C) 2017 The Qt Company Ltd.
-## Contact: http://www.qt.io/licensing/
-##
-## This file is part of the provisioning scripts of the Qt Toolkit.
-##
-## $QT_BEGIN_LICENSE:LGPL21$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see http://www.qt.io/terms-conditions. For further
-## information use the contact form at http://www.qt.io/contact-us.
-##
-## GNU Lesser General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU Lesser
-## General Public License version 2.1 or version 3 as published by the Free
-## Software Foundation and appearing in the file LICENSE.LGPLv21 and
-## LICENSE.LGPLv3 included in the packaging of this file. Please review the
-## following information to ensure the GNU Lesser General Public License
-## requirements will be met: https://www.gnu.org/licenses/lgpl.html and
-## http://www.gnu.org/licenses/old-licenses/lgpl-2.1.html.
-##
-## As a special exception, The Qt Company gives you certain additional
-## rights. These rights are described in The Qt Company LGPL Exception
-## version 1.1, included in the file LGPL_EXCEPTION.txt in this package.
-##
-## $QT_END_LICENSE$
-##
-#############################################################################
-
-# This script installs CMake
-
-# CMake is needed for autotests that verify that Qt can be built with CMake
-
-# shellcheck source=../common/InstallAppFromCompressedFileFromURL.sh
-source "${BASH_SOURCE%/*}/../common/InstallAppFromCompressedFileFromURL.sh"
-
-PrimaryUrl="http://ci-files01-hki.ci.local/input/mac/macos_10.12_sierra/cmake-3.6.2-Darwin-x86_64.tar.gz"
-AltUrl="https://cmake.org/files/v3.6/cmake-3.6.2-Darwin-x86_64.tar.gz"
-SHA1="13835afa3aea939e07a7ecccedcc041dd8c3a86e"
-appPrefix="cmake-3.6.2-Darwin-x86_64"
-
-InstallAppFromCompressedFileFromURL "$PrimaryUrl" "$AltUrl" "$SHA1" "$appPrefix"
-
-echo "export PATH=/Applications/CMake.app/Contents/bin:$PATH" >> ~/.bashrc
-echo "CMake = 3.6.2" >> ~/versions.txt
+BASEDIR=$(dirname "$0")
+$BASEDIR/../common/cmake.sh
diff --git a/coin/provisioning/qtci-macos-10.12-x86_64/035-openssl.sh b/coin/provisioning/qtci-macos-10.12-x86_64/035-openssl.sh
index acd0bd74..a6563ae5 100755
--- a/coin/provisioning/qtci-macos-10.12-x86_64/035-openssl.sh
+++ b/coin/provisioning/qtci-macos-10.12-x86_64/035-openssl.sh
@@ -73,8 +73,8 @@ try
sudo mkdir -p "$path"
sudo ln -s /usr/local/openssl-$opensslVersion $opensslTargetLocation || throw $ExceptionLN
- echo "export PATH=\"$opensslTargetLocation/bin:$PATH\"" >> ~/.bashrc
- echo "export MANPATH=\"$opensslTargetLocation/share/man:$MANPATH\"" >> ~/.bashrc
+ echo "export PATH=\"$opensslTargetLocation/bin:\$PATH\"" >> ~/.bashrc
+ echo "export MANPATH=\"$opensslTargetLocation/share/man:\$MANPATH\"" >> ~/.bashrc
security find-certificate -a -p /Library/Keychains/System.keychain | sudo tee -a $opensslTargetLocation/ssl/cert.pem || throw $ExceptionCertificate
security find-certificate -a -p /System/Library/Keychains/SystemRootCertificates.keychain | sudo tee -a $opensslTargetLocation/ssl/cert.pem || throw $ExceptionCertificate