summaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* Update submodules on '5.8' in qt55.8Qt Submodule Update Bot2017-04-191-0/+0
| | | | | Change-Id: I2dbd8467b77c1a55160396b62bf270d8cdacbb23 Reviewed-by: Liang Qi <liang.qi@qt.io>
* Update submodules on '5.8' in qt5Qt Submodule Update Bot2017-04-191-0/+0
| | | | | Change-Id: Ib8ef3a21c594b3c58fe8b9f51468b3e5f5b33289 Reviewed-by: Liang Qi <liang.qi@qt.io>
* Update submodules on '5.8' in qt5Qt Submodule Update Bot2017-04-181-0/+0
| | | | | Change-Id: I4aa51db4cf07e85ed69cb82fd76dae863dd55db4 Reviewed-by: Liang Qi <liang.qi@qt.io>
* Update submodules on '5.8' in qt5Qt Submodule Update Bot2017-04-141-0/+0
| | | | | Change-Id: I330bfe1c5c1eda6a806feef9cc3b930362245fb5 Reviewed-by: Liang Qi <liang.qi@qt.io>
* Update submodules on '5.8' in qt5Qt Submodule Update Bot2017-04-122-0/+0
| | | | | Change-Id: I707f07be6b8f9238b4c6f9e79f1a9831e81f785d Reviewed-by: Liang Qi <liang.qi@qt.io>
* Update submodules on '5.8' in qt5Qt Submodule Update Bot2017-04-118-0/+0
| | | | | Change-Id: I6b50e79e45b05ff3a2dc5590a87eeb593b9fa2dc Reviewed-by: Liang Qi <liang.qi@qt.io>
* Update submodules on '5.8' in qt5Qt Submodule Update Bot2017-04-067-0/+0
| | | | | Change-Id: I39b5d0e9bddc2f5519cb08ac0b7b538a49a550b4 Reviewed-by: Liang Qi <liang.qi@qt.io>
* Update submodules on '5.8' in qt5Qt Submodule Update Bot2017-04-021-0/+0
| | | | | Change-Id: I9444728a1fa2c23e65a3f809767509a0854f1e2d Reviewed-by: Liang Qi <liang.qi@qt.io>
* Update submodules on '5.8' in qt5Qt Submodule Update Bot2017-04-0112-0/+0
| | | | | Change-Id: I551f0a875c9c16acbcd768994051e85d9fcde47c Reviewed-by: Liang Qi <liang.qi@qt.io>
* Update submodules on '5.8' in qt5Liang Qi2017-03-239-0/+0
| | | | | Change-Id: Icc31f52cf5a77a4100dfd63acd32e1596ead3dad Reviewed-by: Liang Qi <liang.qi@qt.io>
* Update submodules on '5.8' in qt5Liang Qi2017-03-197-0/+0
| | | | | Change-Id: Ibf0175771f357c30243b5d309cfb4facc4a6b31b Reviewed-by: Liang Qi <liang.qi@qt.io>
* Update submodules on '5.8' in qt5Liang Qi2017-03-1511-0/+0
| | | | | Change-Id: Iac3e9b6581b2bb490c8c58ccf50cd4f14b6651a8 Reviewed-by: Liang Qi <liang.qi@qt.io>
* Provision libusb for 64-bit Windows 8 and 10 as wellKari Oikarinen2017-03-142-0/+2
| | | | | | | | Amends 380fca84a9fe583e245355f2e36931473665cf0b. Change-Id: Ia6e1a3bf2465770f55201cd723b329af42984d2b Reviewed-by: Samuli Piippo <samuli.piippo@qt.io> Reviewed-by: Tony Sarajärvi <tony.sarajarvi@qt.io>
* Update submodules on '5.8' in qt5Liang Qi2017-03-0818-0/+0
| | | | | Change-Id: Ic13d3040b541a4b4e9a293885ce49b0b9ba64afa Reviewed-by: Liang Qi <liang.qi@qt.io>
* Provisioning: Upgrade conan version from 0.16.0 to 0.20.2Akseli Salovaara2017-03-031-1/+1
| | | | | | | | | | | | | | | | | | Conan provisioning fails on private Coin instance due to error message Could not find a version that satisfies the requirement conan==0.16.0 (from versions: 0.15.0, 0.16.1, 0.17.2, 0.18.1, 0.19.3, 0.20.0, 0.20.1, 0.20.2) No matching distribution found for conan==0.16.0 Upgrading to 0.16.1 resulted warning "Your conan's client version is deprecated for the current remote (v0.20.2). Upgrade conan client." and provisioning failed with "ERROR: All remotes failed" After upgrade to 0.20.2 conan provisioning script is working again. Change-Id: I2fe9d65460954c929abb4822d206dde42909d5b3 Reviewed-by: Konstantin Tokarev <annulen@yandex.ru>
* Update submodules on '5.8' in qt5Liang Qi2017-02-273-0/+0
| | | | | Change-Id: Icdce897429db6ec02938807bc2add8ae8d9a1ccc Reviewed-by: Liang Qi <liang.qi@qt.io>
* Make top-level configure script more portableSvintsov Dmitry2017-02-241-1/+1
| | | | | | | | | | | Remove hard-coded path to pwd; there is no need to have it, and for example NixOS doesn't actually have it at this location, leading to such an error: ./configure: line 36: /bin/pwd: No such file or directory /qtbase/configure not found. Did you forget to run "init-repository"? Change-Id: If3372db3390ba5f39c5003d12ff2a466f39ff353 Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@qt.io>
* Update submodules on '5.8' in qt5Liang Qi2017-02-244-0/+0
| | | | | Change-Id: Id5ddefcb8bb28109f75b181e5db41ad98519ffc6 Reviewed-by: Liang Qi <liang.qi@qt.io>
* declare optional dependency of qtwebengine on qttoolsOswald Buddenhagen2017-02-231-1/+1
| | | | | | | starting with 5.7, it optionally comes with a qt designer plugin. Change-Id: Idcc81b2688a1c09d3273b07a1ec991b54903e94c Reviewed-by: Michal Klocek <michal.klocek@qt.io>
* Update submodules on '5.8' in qt5Liang Qi2017-02-236-0/+0
| | | | | Change-Id: I81b3b50b87402c49a306d381c2d107fc6d4d91da Reviewed-by: Liang Qi <liang.qi@qt.io>
* Update submodules on '5.8' in qt5Liang Qi2017-02-197-0/+0
| | | | | Change-Id: I2a905ff8300b2f64537446ee763202eeed216c6e Reviewed-by: Liang Qi <liang.qi@qt.io>
* Merge remote-tracking branch 'origin/5.6' into 5.8Liang Qi2017-02-179-0/+471
|\ | | | | | | Change-Id: I0203dea8e441e58400d6c44697588a44b97a522b
| * Update submodules on '5.6' in qt5Liang Qi2017-02-119-0/+0
| | | | | | | | | | Change-Id: I2b0758eeb79aedf3450e857fc3e29de6d3659d47 Reviewed-by: Liang Qi <liang.qi@qt.io>
| * Provisioning: Update opengl32.dll x86 on Windows 10 x64Akseli Salovaara2017-02-101-0/+63
| | | | | | | | | | | | | | | | | | | | OpenGL32 update is needed for autotests to pass. At least tst_qglbuffer vertexBuffer will fail without an update. This update is already in place on Windows x86 and x64 CI hosts but applied only to System32 -folders. Change-Id: I223ffc53ecba77030385f29463c419acdc12e1a3 Reviewed-by: Tony Sarajärvi <tony.sarajarvi@qt.io>
| * Provisioning: Install postgresql x86 and x64 libraries to Windows 10Akseli Salovaara2017-02-101-0/+84
| | | | | | | | | | | | | | | | Install both x86 and x64 libraries in order to enable Windows x86 builds on Windows x64 hosts. Environment variables are used by Coin. Change-Id: Ied654efb2f33ab1c643f38a1ea50a127aeb7af7e Reviewed-by: Tony Sarajärvi <tony.sarajarvi@qt.io>
| * Provisioning: Install OpenSSL x86 and x64 libraries to Windows 10 x64Akseli Salovaara2017-02-101-0/+86
| | | | | | | | | | | | | | | | Install both x86 and x64 libraries in order to enable Windows x86 builds on Windows x64 hosts. Environment variables are used by Coin. Change-Id: Idada7fc41202298c6f1b2919f0f4343b717e890a Reviewed-by: Tony Sarajärvi <tony.sarajarvi@qt.io>
| * Provisioning: Install MySQL x86 and x64 libraries to Windows10 x64Akseli Salovaara2017-02-101-0/+112
| | | | | | | | | | | | | | | | Install both x86 and x64 libraries in order to enable Windows x86 builds on Windows x64 hosts. Environment variables are used by Coin. Change-Id: I8eea51a0bfd05bc72d1d004649211c7bc5901d97 Reviewed-by: Tony Sarajärvi <tony.sarajarvi@qt.io>
| * Provisioning: Visual Studio 2015 with update 3Heikki Halmet2017-02-073-0/+124
| | | | | | | | | | | | | | | | | | Common install script for Visual Studio installation and updates. Latest Visual Studio 2015 update is required for releases Change-Id: I5b41625ca7f161b4ba2d417797f8839ef175cdbc Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
| * Upgrade CMake to 3.6.2Konstantin Tokarev2017-02-073-0/+12
| | | | | | | | | | | | | | | | | | | | QtWebKit requires CMake >= 2.8.12, while only 2.8.11 is available on Windows 10 machines. Task-number: QTQAINFRA-996 Change-Id: I734be4cc36f64dd5aeb243b0fbe4395c75c523b3 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> (cherry picked from commit 77eeee64a43c5c448321b8f5ac7b64c872e14489)
| * Upgrade CMake to 3.6.2 on Windows 7 builderKonstantin Tokarev2017-02-071-0/+1
| | | | | | | | | | | | | | Task-number: QTQAINFRA-996 Change-Id: I84867a5b630c4cf1e712047c58c6cad9e5e43800 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> (cherry picked from commit daa865312104e7d5d073b0a63e0f50c8a04b9697)
| * Upgrade CMake to 3.6.2 on Windows 8Simo Fält2017-02-072-0/+2
| | | | | | | | | | | | | | Pyside requires CMake 3.0 or higher Change-Id: Ic3f7eb4e89cd022364b1437fa8ff4476c86c3e47 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
* | Update qtwebengine manually againLiang Qi2017-02-171-0/+0
| | | | | | | | | | Change-Id: I6fabfa3a4ce0b0fbcb1da2e15bdf5f8f6ac6e643 Reviewed-by: Liang Qi <liang.qi@qt.io>
* | Update qtwebengine manuallyLiang Qi2017-02-161-0/+0
| | | | | | | | | | Change-Id: I86dc97895dbbbff1a14e90d0a7c2ae359ce25891 Reviewed-by: Liang Qi <liang.qi@qt.io>
* | Update submodules on '5.8' in qt5Liang Qi2017-02-156-0/+0
| | | | | | | | | | Change-Id: Idb3b5cdd408d20582f10372a0e42e6f63e7a94bc Reviewed-by: Liang Qi <liang.qi@qt.io>
* | Update submodules on '5.8' in qt5Liang Qi2017-02-129-0/+0
| | | | | | | | | | Change-Id: If01fe1a84460b65322bfe9d8c402f24d44e98094 Reviewed-by: Liang Qi <liang.qi@qt.io>
* | Update submodules on '5.8' in qt5Liang Qi2017-02-0816-0/+0
| | | | | | | | | | Change-Id: I8c13bd75500b5fe21bde113b40b4e4161b8355f0 Reviewed-by: Liang Qi <liang.qi@qt.io>
* | Update qtbase manuallyLiang Qi2017-02-061-0/+0
| | | | | | | | | | Change-Id: I2e9330f0f037bd8637c4391fe5abde613aadc2ea Reviewed-by: Liang Qi <liang.qi@qt.io>
* | Merge "Merge remote-tracking branch 'origin/5.6' into 5.8" into refs/staging/5.8Liang Qi2017-02-046-24/+176
|\ \
| * \ Merge remote-tracking branch 'origin/5.6' into 5.8Simon Hausmann2017-02-036-24/+176
| |\ \ | | |/ | | | | | | | | | | | | | | | Conflicts: coin/provisioning/qtci-linux-RHEL-6.6-x86_64/android_linux.sh Change-Id: I10fcdfc0af68741d931f4732783bafdad2fffc4a
| | * Provision: Storage android sdk and ndk version informationHeikki Halmet2017-02-031-18/+30
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Sdk and ndk version information will be storaged to versions.txt. Versions.txt will be used for all provision scripts and later on it's data will be printed to provision log. Also script name changed to match both android sdk and ndk. Change-Id: I3366e596f539099c3b587466d90905d0889398fe Reviewed-by: Tony Sarajärvi <tony.sarajarvi@qt.io>
| | * Provision: Script to print sw versions to provision logHeikki Halmet2017-02-032-0/+87
| | | | | | | | | | | | | | | | | | | | | | | | This script is the last script that is run by provisioning. It will print all storaged sw information to provision log Change-Id: I2c76d5f7cccf9c116cb660ffcb67d3bece473da8 Reviewed-by: Tony Sarajärvi <tony.sarajarvi@qt.io>
| | * Update jom to 1.1.2Joerg Bornemann2017-02-031-3/+3
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | The most important changes that affect the CI are: - Fixed bogus path in error message for failed targets. - Fixed error "JobClient destroyed while still acquiring." that could be yielded for failed builds. - Fixed /k option (QTCREATORBUG-17131). - Added the special .NOTPARALLEL target that disables parallel build for the containing makefile. (This one is needed to build QtWebEngine in debug-and-release properly.) - Introduced the JOMFLAGS environment variable. This is a MAKEFLAGS pendant. JOMFLAGS is useful to set up separate flags for nmake and jom. Change-Id: Icb2462d06b000a3fe29e1e9290b294cb1e900409 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
| | * Revert "Clean up usage of qtsvg as dependency"Frederik Gladhorn2017-02-031-3/+3
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | qtdeclarative has a runtime dependency, some tests rely on the svg module being available, so in order to not reduce the test coverage, revert this change. I'd like to see a better/cleaner separation, but for the time being, better coverage wins. This reverts commit fbd782636b6ee413d2b6e8bca408263297194254. Change-Id: I60d6b585e25e2e7c4f6ad705b754279968827842 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> Reviewed-by: Jędrzej Nowacki <jedrzej.nowacki@qt.io> Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@qt.io>
| | * Provision: Script for linux to remove preinstalled softwareHeikki Halmet2017-02-031-0/+49
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Script to remove tier1's preinstalled software. Script itself includes all information about the software that needs to be removed from tier2 before provision starts to run installations. When this script is run for certain platform that platform needs to provision all removed software back to tier2 template. So user needs to make sure that all needed provision script are available when calling this removal-script. Goal is to have vanilla os when provision don't need to remove any software before installations. When this goal is reached this script and script calls can be removed from provision. Change-Id: I048909800807fabb1dc599e768a90e7457fbc2cf Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
* | | Update submodules on '5.8' in qt5Liang Qi2017-02-0423-0/+0
|/ / | | | | | | | | Change-Id: Ic3a06dd310fd7b67b53b95c8f6b1ef8813449fe5 Reviewed-by: Liang Qi <liang.qi@qt.io>
* | Provision libusb-1.0 for WindowsKari Oikarinen2017-01-314-0/+50
| | | | | | | | | | | | | | It's needed by tqtc-boot2qt/qdb. Change-Id: Id5b8b18a2090c040c3eec1bd3c4c521456245381 Reviewed-by: Tony Sarajärvi <tony.sarajarvi@qt.io>
* | Add PS provisioning helper for 7-Zip filesKari Oikarinen2017-01-311-0/+23
| | | | | | | | | | Change-Id: Ice10e54137da8a0d2372019a195a63121fd00a8a Reviewed-by: Tony Sarajärvi <tony.sarajarvi@qt.io>
* | Merge remote-tracking branch 'origin/5.6' into 5.8Liang Qi2017-01-2814-0/+349
|\ \ | |/ | | | | | | Task-number: QTBUG-58371 Change-Id: Ic3ec10a04ec9fcfea38324f6052b2d082c6ece58
| * Android sdk and ndk to provisioning for Windows 7Heikki Halmet2017-01-285-0/+74
| | | | | | | | | | | | | | | | | | | | Installs latest Android sdk and ndk. It also runs update for SDK API level 18, latest SDK- and platform- tools and build-tools version 23.0.3. Task-number: QTBUG-58369 Change-Id: Ib42f5149243fc5d262f6542e26726d1c8cbb2e8c Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
| * Provision: Set bash_profile to read .bashrcHeikki Halmet2017-01-242-0/+10
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | The method (vmware tools) of launching a process inside a virtual machine results in the launch of a process that does not originate from a login shell. Therefore the CI system explicitly starts the agent with "bash -l -c" to enforce the invocation as login shell and thus execute settings from /etc/profile, ~/.bash_profile, etc. This brings the behavior of the system closer to what we see as developers. However the shell is a non-interactive shell, therefore ~/.bashrc is not read by default. On Linux systems such as RHEL, ~/.bash_profile is configured to still read ~/.bashrc. For consistency we apply the same logic to the macOS configurations. Change-Id: I417ecd7866bc4ae1b50beb14c19b456588b4050a Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>