summaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
...
* | | | COIN Provisioning: Disable selinux in rhel 7.2Simo Fält2016-09-281-0/+5
| | | | | | | | | | | | | | | | | | | | Change-Id: I03c2b70e4c05440c6cf1a6d355f5800c67f62bb7 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
* | | | Update submodules on '5.8' in qt5Qt Submodule Update Bot2016-09-2812-0/+0
| | | | | | | | | | | | | | | | | | | | Change-Id: Ia2e717ea4f71a3032146f3fc8b98f96d141f1f92 Reviewed-by: Jani Heikkinen <jani.heikkinen@qt.io>
* | | | Update submodules on '5.8' in qt5Qt Submodule Update Bot2016-09-2512-0/+0
| | | | | | | | | | | | | | | | | | | | Change-Id: Iec230ba54c75039fe1b0506540e52a598fff2510 Reviewed-by: Liang Qi <liang.qi@qt.io>
* | | | Update submodules on '5.8' in qt5Qt Submodule Update Bot2016-09-245-0/+0
| | | | | | | | | | | | | | | | | | | | Change-Id: Ie862b6f2ec78e6c24f8f5bd0ee959e598f3d33d8 Reviewed-by: Liang Qi <liang.qi@qt.io>
* | | | Update submodules on '5.8' in qt5Qt Submodule Update Bot2016-09-2212-0/+0
| | | | | | | | | | | | | | | | | | | | Change-Id: Ic9386ba7ad3b9a28180719440af6eeb64f4483ff Reviewed-by: Liang Qi <liang.qi@qt.io>
* | | | Provision libusb-1.0 for LinuxKari Oikarinen2016-09-213-1/+9
| | | | | | | | | | | | | | | | | | | | | | | | | | | | It is a dependency of tqtc-boot2qt/qdb, which will join CI soon. Change-Id: I3b205877e705f554202ab7171f9d828491b95ac6 Reviewed-by: Heikki Halmet <heikki.halmet@qt.io>
* | | | Update submodules on '5.8' in qt5Qt Submodule Update Bot2016-09-2030-0/+0
| | | | | | | | | | | | | | | | | | | | Change-Id: Ic49edc7055336d6717fdd985798f665db3803384 Reviewed-by: Liang Qi <liang.qi@qt.io>
* | | | Make sure to install gtk 3 and gstreamer on RHEL 7Frederik Gladhorn2016-09-151-0/+7
| | | | | | | | | | | | | | | | | | | | Change-Id: I95c570431c5b78e24754b6e08be0172071da3c51 Reviewed-by: Simo Fält <simo.falt@theqtcompany.com>
* | | | Update submodules on '5.8' in qt5Qt Submodule Update Bot2016-09-1518-0/+0
| | | | | | | | | | | | | | | | | | | | Change-Id: Ibe4e45b892e4e1caae53808b916bc13630ab88f9 Reviewed-by: Liang Qi <liang.qi@qt.io>
* | | | automatically launch new configure system in top-level buildsOswald Buddenhagen2016-09-152-4/+34
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | this includes moving the -skip option here, where it belongs. the implementation is a bit hacky, but the proper one would be vastly more complex: we'd have to load all modules, then parse the command line properly (the -skip parsing would be a custom callback, to avoid needing to process features), then discard all now excluded modules again, then re-process the command line (so we can complain about options which are now invalid), and only now proceed with the actual feature processing. that seems a bit over the top, so we accept that -skip cannot be the argument of another option, which seems quite reasonable. Change-Id: I0053658e6d7e11b82cdfe55893cb553b664a9298 Reviewed-by: Jake Petroules <jake.petroules@qt.io> Reviewed-by: Frederik Gladhorn <frederik.gladhorn@qt.io>
* | | | Merge remote-tracking branch 'origin/5.7' into 5.8Liang Qi2016-09-131-0/+101
|\ \ \ \ | |/ / / | | | | | | | | Change-Id: I62235fec5e9b8b81e41d64bfcf58067dc1213d0c
| * | | Merge remote-tracking branch 'origin/5.6' into 5.7Liang Qi2016-09-121-0/+101
| |\ \ \ | | |/ / | | | | | | | | | | | | | | | | | | | | Conflicts: coin/provisioning/qtci-linux-RHEL-6.6-x86_64/android_sdk_linux.sh Change-Id: Ib972234bb644353db6920b2dcbe1fd4775ef1779
| | * | Android sdk and ndk to provisioning for qt5.6Heikki Halmet2016-09-121-0/+105
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Install latest Android sdk and ndk. It also runs update for SDK API level 18, latest SDK- and platform- tools and build-tools version 23.0.3. Build-tools version 23.0.3 is the latest usable version for Red Hat 6. Newer version of build-tools, version 24.x.x, requires GLIBC_2.14, which is not available in Red Hat 6. Change-Id: Iddc353674a65e0af7a9036d9296b9c2933fa114f Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
| | * | Update submodules on '5.6' in qt5Qt Submodule Update Bot2016-09-069-0/+0
| | | | | | | | | | | | | | | | | | | | | | | | Change-Id: I1f0e77afca353b07420ed8da001cfbbaaa738dce Reviewed-by: Qt Submodule Update Bot <qt_submodule_update_bot@qt-project.org> Reviewed-by: Liang Qi <liang.qi@qt.io>
| | * | Update submodules on '5.6' in qt5Qt Submodule Update Bot2016-09-042-0/+0
| | | | | | | | | | | | | | | | | | | | Change-Id: I34bab96a9ec73aa07e1295250aa85528f306a679 Reviewed-by: Qt Submodule Update Bot <qt_submodule_update_bot@qt-project.org>
| | * | Update submodules on '5.6' in qt5Qt Submodule Update Bot2016-09-028-0/+0
| | | | | | | | | | | | | | | | | | | | Change-Id: I565078e5d2d1d8b6a9111d3f063eaebafe008c6f Reviewed-by: Liang Qi <liang.qi@qt.io>
| | * | Update submodules on '5.6' in qt5Qt Submodule Update Bot2016-08-3013-0/+0
| | |/ | | | | | | | | | | | | Change-Id: I45ed20f8f12335ac2d7aa315329a25c8fbac94fa Reviewed-by: Qt Submodule Update Bot <qt_submodule_update_bot@qt-project.org>
| | * Update submodules on '5.6' in qt5Qt Submodule Update Bot2016-08-2213-0/+0
| | | | | | | | | | | | | | | Change-Id: I1104beac8bafb324731879efdb752a1cebbb9512 Reviewed-by: Qt Submodule Update Bot <qt_submodule_update_bot@qt-project.org>
| | * Update submodules on '5.6' in qt5Qt Submodule Update Bot2016-08-1610-0/+0
| | | | | | | | | | | | | | | Change-Id: I3fbdb4edc4d37a8b25fdaff52853d672c951891d Reviewed-by: Qt Submodule Update Bot <qt_submodule_update_bot@qt-project.org>
| | * Update submodules on '5.6' in qt5Qt Submodule Update Bot2016-08-1312-0/+0
| | | | | | | | | | | | | | | Change-Id: I4821c386e318139e13ad228983c43c1b1d978494 Reviewed-by: Qt Submodule Update Bot <qt_submodule_update_bot@qt-project.org>
| | * Update submodules on '5.6' in qt5Qt Submodule Update Bot2016-08-1012-0/+0
| | | | | | | | | | | | | | | Change-Id: I166e0f9a092f7e293d50d7efb12df54bcee5ec13 Reviewed-by: Liang Qi <liang.qi@qt.io>
| * | Update submodules on '5.7' in qt5Qt Submodule Update Bot2016-09-077-0/+0
| | | | | | | | | | | | | | | Change-Id: Ic053fa3b81c674e4a63419bdab848e362b2a93a6 Reviewed-by: Liang Qi <liang.qi@qt.io>
| * | Update submodules on '5.7' in qt5Qt Submodule Update Bot2016-09-0313-0/+0
| | | | | | | | | | | | | | | Change-Id: I8309b4fd697efb7b539c84d0c351b25c230a4950 Reviewed-by: Qt Submodule Update Bot <qt_submodule_update_bot@qt-project.org>
| * | Update submodules on '5.7' in qt5Qt Submodule Update Bot2016-08-2614-0/+0
| | | | | | | | | | | | | | | Change-Id: I726579f7e3e25774dc882c1c9d4780ccf23deaed Reviewed-by: Liang Qi <liang.qi@qt.io>
| * | fix branches of qtpim and qtsystemsOswald Buddenhagen2016-08-181-2/+2
| | | | | | | | | | | | | | | | | | | | | | | | these repos were definitely _not_ branched for 5.7. Change-Id: Ib31d4e07f2651cfba0a7d31a9db1f1a812061313 Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io> Reviewed-by: Liang Qi <liang.qi@qt.io>
| * | Update submodules on '5.7' in qt5Qt Submodule Update Bot2016-08-188-0/+0
| | | | | | | | | | | | | | | Change-Id: I8b849ebf5685a65206d1c60d1c3f7b85e3e6716d Reviewed-by: Qt Submodule Update Bot <qt_submodule_update_bot@qt-project.org>
| * | Update submodules on '5.7' in qt5Qt Submodule Update Bot2016-08-1111-0/+0
| | | | | | | | | | | | | | | Change-Id: I5494d36a2b93a85acbc5825f5bd73d032a4098a9 Reviewed-by: Qt Submodule Update Bot <qt_submodule_update_bot@qt-project.org>
| * | Update submodules on '5.7' in qt5Qt Submodule Update Bot2016-08-071-0/+0
| | | | | | | | | | | | | | | Change-Id: I0f7724142af344e35897035016b03ce046c8164e Reviewed-by: Qt Submodule Update Bot <qt_submodule_update_bot@qt-project.org>
| * | Update submodules on '5.7' in qt5Qt Submodule Update Bot2016-08-061-0/+0
| | | | | | | | | | | | | | | Change-Id: I59475dd0549f9c4c83ad830a76b3b5225aa90eda Reviewed-by: Qt Submodule Update Bot <qt_submodule_update_bot@qt-project.org>
| * | Update submodules on '5.7' in qt5Qt Submodule Update Bot2016-08-064-0/+0
| | | | | | | | | | | | | | | Change-Id: I92e5272d0d0662bfed36e2fa51d25b729e89a172 Reviewed-by: Liang Qi <liang.qi@qt.io>
* | | Update submodules on '5.8' in qt5Qt Submodule Update Bot2016-09-0815-0/+0
| | | | | | | | | | | | | | | Change-Id: I4bd1038cd3ee8cefcfb27179527511c41a0af799 Reviewed-by: Liang Qi <liang.qi@qt.io>
* | | Update submodules on '5.8' in qt5Qt Submodule Update Bot2016-09-0511-0/+0
| | | | | | | | | | | | | | | Change-Id: Ic507adbb59d9a95afa4c188223f8e0a5d2d5d03c Reviewed-by: Liang Qi <liang.qi@qt.io>
* | | Update submodules on '5.8' in qt5v5.8.0-alpha1Qt Submodule Update Bot2016-09-0115-0/+0
| | | | | | | | | | | | | | | Change-Id: I457d16bb5c82d98dfc0995e84c08fee89d872e89 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
* | | Update submodules on '5.8' in qt5Qt Submodule Update Bot2016-08-296-0/+0
| | | | | | | | | | | | | | | Change-Id: I165c8b4ae2709d009462b7fa5b91561759524e5f Reviewed-by: Jani Heikkinen <jani.heikkinen@qt.io>
* | | Update submodules on '5.8' in qt5Qt Submodule Update Bot2016-08-2817-0/+0
| | | | | | | | | | | | | | | Change-Id: I558721d2b7a630453ce794e7b7b97e1fca5ef3dc Reviewed-by: Jani Heikkinen <jani.heikkinen@qt.io>
* | | Remove qtsystems from the list of recommended modules in qtlocationSimon Hausmann2016-08-281-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | QtSystems is not a supported module at the moment, and the code in QtLocation to utilize QtSystems is behind an #ifdef and destined for removal. Change-Id: Ide44f138638ccd751044c13c289f1e116641a23e Reviewed-by: Alex Blasche <alexander.blasche@qt.io>
* | | Update submodules on '5.8' in qt5Qt Submodule Update Bot2016-08-2430-0/+0
| | | | | | | | | | | | | | | Change-Id: I188c217abff06c901f6da7561bc7ed1f3c12d8b1 Reviewed-by: Frederik Gladhorn <frederik.gladhorn@qt.io>
* | | Removed TP status from qtscxml and qtserialbusJani Heikkinen2016-08-241-2/+2
| | | | | | | | | | | | | | | Change-Id: I8ed4edcdf9eab48ec1ac278d3e8de38149b0fd8d Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@theqtcompany.com>
* | | Merge remote-tracking branch 'origin/dev' into 5.8Oswald Buddenhagen2016-08-242-2/+9
|\ \ \ | | | | | | | | | | | | | | | | | | | | | | | | Note that this also contains the adjustment of the branch for the latecomers qtspeech and qtnetworkauth. Change-Id: Ia77eb4d47a6ad66cb35e50ae03af751f46a805a8
| * | | Add qtnetworkauthJesus Fernandez2016-08-222-0/+7
| | | | | | | | | | | | | | | | | | | | | | | | Change-Id: I4cd81725d0aec29ff3252a84504a81a44d1b60eb Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> Reviewed-by: Jędrzej Nowacki <jedrzej.nowacki@theqtcompany.com>
| * | | Make QtSpeech a tech preview release for Qt 5.8Frederik Gladhorn2016-08-172-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | Change-Id: I144109a45bece4b2283c24ad7aae64c098f86963 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> Reviewed-by: Maurice Kalinowski <maurice.kalinowski@qt.io>
| * | | Update submodules on 'dev' in qt5Qt Submodule Update Bot2016-08-1718-0/+0
| | | | | | | | | | | | | | | | | | | | Change-Id: Ie425f3f5a64e83702a6987d2892fbfa68bea5844 Reviewed-by: Liang Qi <liang.qi@qt.io>
* | | | Adjust submodule branchesOswald Buddenhagen2016-08-081-38/+38
|/ / / | | | | | | | | | Change-Id: I6e8c8e91b7e17efa93b24e8026fa3f340bd10e9d
* | | Merge remote-tracking branch 'origin/5.7' into devLiang Qi2016-08-063-3/+11
|\ \ \ | |/ / | | | | | | Change-Id: I91cf0b6132a73c34c63d83a0bee1c028f2f819f8
| * | Merge remote-tracking branch 'origin/5.6' into 5.7Liang Qi2016-08-052-0/+6
| |\ \ | | |/ | | | | | | Change-Id: I1a08537bcd4748ebbb3e5a670e3a099779f33945
| | * Update submodules on '5.6' in qt5Qt Submodule Update Bot2016-08-0413-0/+0
| | | | | | | | | | | | | | | Change-Id: I32152358542e406f773d106abba25ee5609c6469 Reviewed-by: Qt Submodule Update Bot <qt_submodule_update_bot@qt-project.org>
| | * Fix Coin provisioning in RHEL 6 regarding sslclientkey valuesTony Sarajärvi2016-08-032-0/+6
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | There was a bug in RHELs subscription manager that caused yum not to work by fetching incorrect data into the sslclientkey repository parameter value. This provisioning script fetches new data for the repository and thus fixes yum. Naturally by not having a template where a bad repository exists, this script would be obsolete. Also, as this needs to be run before any other scripts using yum, prefixes were added to the scripts. Change-Id: I5c6ed1d43451d2918f9b6dad22b0106339f36aea Reviewed-by: Frederik Gladhorn <frederik.gladhorn@qt.io>
| | * Update submodules on '5.6' in qt5Qt Submodule Update Bot2016-07-3025-0/+0
| | | | | | | | | | | | | | | Change-Id: Ie6bd9ea82d5e67fee7645dccd9b07ceac5755582 Reviewed-by: Liang Qi <liang.qi@qt.io>
| | * Updated submodulesQt Submodule Update Bot2016-07-045-0/+0
| | | | | | | | | | | | | | | Change-Id: Ia80e4d39f9772e32952685008380cc348f481c6c Reviewed-by: Qt Submodule Update Bot <qt_submodule_update_bot@qt-project.org>
| | * Updated submodulesQt Submodule Update Bot2016-07-047-0/+0
| | | | | | | | | | | | | | | Change-Id: I5443b0f4d97cfc076e3a642ae78770b38661e983 Reviewed-by: Qt Submodule Update Bot <qt_submodule_update_bot@qt-project.org>