summaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* Update submodules on '5.11.0' in qt5v5.11.0-rc2v5.11.0wip/qt3dstudio/2.0wip/qt3d-runtime/2.0wip/pyside-setup/5.11.0Qt Submodule Update Bot2018-05-161-0/+0
| | | | | Change-Id: Ibd0c5cf8c72518bd5bb608dfe3c7946f6bc2d121 Reviewed-by: Jani Heikkinen <jani.heikkinen@qt.io>
* Update submodules on '5.11.0' in qt5Qt Submodule Update Bot2018-05-162-0/+0
| | | | | Change-Id: I4de0d56b6bd15782984f67e4107b7ec9a90731e4 Reviewed-by: Jani Heikkinen <jani.heikkinen@qt.io>
* Update submodules on '5.11.0' in qt5Qt Submodule Update Bot2018-05-153-0/+0
| | | | | Change-Id: I13dae70cd516b623c9e9039a6c8b71de84e88459 Reviewed-by: Jani Heikkinen <jani.heikkinen@qt.io>
* Fix linking of qdoc against an external libclang (part 1)Simon Hausmann2018-05-142-0/+13
| | | | | | | | | | | This is the qt5 part of the fix for the task. For the special version of libclang we hacked together that allows static linkage, set an environment variable that the mighty qdoc build system can utilize to activate the release packaging specific linkage. Change-Id: Ie340955214585329fe8fd3bc790e3cd6c6be42f9 Task-number: QTBUG-68178 Reviewed-by: Jędrzej Nowacki <jedrzej.nowacki@qt.io>
* Update submodules on '5.11.0' in qt5Qt Submodule Update Bot2018-05-093-0/+0
| | | | | Change-Id: Ia6d3ee44db368765612cea543952878499889d6b Reviewed-by: Jani Heikkinen <jani.heikkinen@qt.io>
* Update submodules on '5.11.0' in qt5v5.11.0-rc1Qt Submodule Update Bot2018-05-042-0/+0
| | | | | Change-Id: I73fe6947d8ffdf56ea77e9aab5eb89955a0eed2f Reviewed-by: Liang Qi <liang.qi@qt.io>
* Update submodules on '5.11.0' in qt5Qt Submodule Update Bot2018-05-036-0/+0
| | | | | Change-Id: I37be73eba9442b56b5f7147e7d69b98ce464b44d Reviewed-by: Liang Qi <liang.qi@qt.io>
* Install the MinGW build of libclangSimon Hausmann2018-05-014-4/+17
| | | | | | | | | | | | | | This restores the MinGW installation of libclang on Windows 7 and installs the MSVC and MinGW builds in parallel on Windows 10. For compatibility reasons the MSVC installation is done last, to ensure that the older LLVM_INSTALL_DIR variable points to the MSVC installation. In addition though we now get LLVM_INSTALL_DIR_MINGW and LLVM_INSTALL_DIR_MSVC, which qt_find_clang.prf in qttools can use in the future. Task-number: QTBUG-66015 Change-Id: I8b53b85d0cde597c88a089f2a05f03947828d9bd Reviewed-by: Simo Fält <simo.falt@qt.io>
* Update submodules on '5.11.0' in qt5Qt Submodule Update Bot2018-04-282-0/+0
| | | | | Change-Id: If2f1f76270195f337803ba302e46049acb015e3c Reviewed-by: Liang Qi <liang.qi@qt.io>
* Update submodules on '5.11.0' in qt5Qt Submodule Update Bot2018-04-2824-0/+0
| | | | | Change-Id: Ica9fca497f78dd4660118814acce3a4c2c0e68b7 Reviewed-by: Liang Qi <liang.qi@qt.io>
* Update clang version to 6.0Jędrzej Nowacki2018-04-288-22/+9
| | | | | | | | | | | | | | | | The version also contains statically compiled libraries so we can ship qdoc without shipping libclang. The change temporarly removes CI qdoc builds from RHEL6 and MinGW, these two configurations are not used for packaging, just for CI testing. We should restore MinGW later. Task-number: QTBUG-66015 Task-number: QTBUG-67764 Change-Id: Ie37b4be6a639e81d9ef0815682c6d60981cbeaae Reviewed-by: Jesus Fernandez <Jesus.Fernandez@qt.io> Reviewed-by: Fredrik de Vibe <fredrik.devibe@qt.io> Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
* Update submodules on '5.11.0' in qt5Qt Submodule Update Bot2018-04-2425-0/+0
| | | | | Change-Id: I16b8e45bd4dff9470299aced9fdf5302878f61f8 Reviewed-by: Liang Qi <liang.qi@qt.io>
* Merge remote-tracking branch 'origin/5.11' into 5.11.0Liang Qi2018-04-201-0/+3
|\ | | | | | | Change-Id: Ida278c6731466e7de8c9dc9115a948488869a746
| * Provisioning: openSUSE-42.3: Install libpulse-develTopi Reinio2018-04-171-0/+3
| | | | | | | | | | | | | | | | | | Required by Qt Multimedia. Task-number: QTBUG-64538 Change-Id: I12e5a1b1a6390f553d883ce12647475eb9dd2992 Reviewed-by: Joni Jäntti <joni.jantti@qt.io> Reviewed-by: Tony Sarajärvi <tony.sarajarvi@qt.io>
* | Update submodules on '5.11.0' in qt5Qt Submodule Update Bot2018-04-1826-0/+0
| | | | | | | | | | Change-Id: Ie95476e1e3f240b8a55da79b09c65736f240272e Reviewed-by: Liang Qi <liang.qi@qt.io>
* | Merge remote-tracking branch 'origin/5.11' into 5.11.0Liang Qi2018-04-1725-77/+276
|\ \ | |/ | | | | Change-Id: Id0540cee408413b7f5ab7410f3d1db3f38fd46af
| * Revert "Install Python 2.7.13 to RHEL with pip"wip/navigationSimo Fält2018-04-161-5/+6
| | | | | | | | | | | | | | | | | | This reverts commit 794913dde77e9a2918353894a33d03b16e6927c4, which seems to break pyside builds. Instead we install python-pip package from the EPEL repository. Change-Id: Ic84680b0b0d6950d389bb42a6add18c83256f00f Reviewed-by: Tony Sarajärvi <tony.sarajarvi@qt.io>
| * Update submodules on '5.11' in qt5v5.11.0-beta4Qt Submodule Update Bot2018-04-157-0/+0
| | | | | | | | | | Change-Id: I18750ffb5810a3f60a2b615ca487ce42459d560d Reviewed-by: Liang Qi <liang.qi@qt.io>
| * Provisioning: Add test for squish installationHeikki Halmet2018-04-152-1/+38
| | | | | | | | | | | | | | | | | | | | | | | | | | | | Squish is needed by RTA which is not run during normal qt5 build. Other words squish installation is not tested during integration. That's why we need separate test for it. This change will fetch test and run test suite which is made to check that squish installation works Task-number: QTQAINFRA-1733 Change-Id: I9284fd52d87767ae04022c3a6996e0bb972315dd Reviewed-by: Johanna Äijälä <johanna.aijala@qt.io> Reviewed-by: Joni Jäntti <joni.jantti@qt.io> Reviewed-by: Matti Paaso <matti.paaso@qt.io>
| * Provisioning: Ubuntu - Add QNX 6.6.0Joni Jantti2018-04-152-0/+104
| | | | | | | | | | | | | | | | QNX 6.6.0 is required by RTA. Task-number: QTQAINFRA-1914 Change-Id: Id0578050d24fb13f3e10a10e972be790d39f9bc0 Reviewed-by: Tony Sarajärvi <tony.sarajarvi@qt.io>
| * Provisioning: Win10_x86 - mysqlJoni Jantti2018-04-151-0/+1
| | | | | | | | | | | | | | | | Required by RTA. Task-number: QTQAINFRA-1923 Change-Id: I13d78da0bd3ea2fa8a75734fb5f88a472cbd79de Reviewed-by: Tony Sarajärvi <tony.sarajarvi@qt.io>
| * Provisioning: Win10_x86 - opensslJoni Jantti2018-04-151-0/+1
| | | | | | | | | | | | | | | | Required by RTA. Task-number: QTQAINFRA-1923 Change-Id: I4937980a1f23d56e509b71541605c80cb6423402 Reviewed-by: Tony Sarajärvi <tony.sarajarvi@qt.io>
| * Provisioning: Win10_x86 - psqlJoni Jantti2018-04-151-0/+1
| | | | | | | | | | | | | | | | Required by RTA. Task-number: QTQAINFRA-1923 Change-Id: Ia13d9586d1c1934c8c4e51fcbe9ce826bba68524 Reviewed-by: Tony Sarajärvi <tony.sarajarvi@qt.io>
| * Provisioning: Win10_x86 - Windows 10 SDK with debugging toolsJoni Jantti2018-04-152-0/+51
| | | | | | | | | | | | | | RTA needs debugging tools for Windows 10 x86 testing. Change-Id: I69cae92a2529a933a018f22c1b200bdc4d2c0aa0 Reviewed-by: Tony Sarajärvi <tony.sarajarvi@qt.io>
| * Fix squish provisioning script typoTony Sarajärvi2018-04-151-2/+2
| | | | | | | | | | Change-Id: If33847a552fe40128cef577b99adf3152de3a9e2 Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@qt.io>
| * Fix shellcheck complaints in RHEL 6.6 provisioning scriptsTony Sarajärvi2018-04-158-13/+21
| | | | | | | | | | | | Change-Id: Idb4240b4cfd309b2c6c418e8c18b175a491f8eea Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@qt.io> Reviewed-by: Heikki Halmet <heikki.halmet@qt.io>
| * Update submodules on '5.11' in qt5Liang Qi2018-04-1515-0/+0
| | | | | | | | | | Change-Id: I5b4c4043f2bfb2bf3e62bc06e244a4fec3e5bbd6 Reviewed-by: Liang Qi <liang.qi@qt.io>
| * Provisioning: Install Git Large File StorageHeikki Halmet2018-04-151-0/+43
| | | | | | | | | | | | | | | | This tool is needed to clone some repositories correctly Task-number: QTQAINFRA-1921 Change-Id: If4744304490649aeecf9daa0c1f840ded9b7beed Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
| * Provisioning: Use wayland libs provided by distroHeikki Halmet2018-04-153-124/+6
| | | | | | | | | | | | | | | | | | | | | | | | Redhat repositories includes needed wayland libraries. Let's use those instead providing those through provisioning. Task-number: QTQAINFRA-1925 Change-Id: I543a6b9fb8876f64d4b9c17ef909b9c61129e62e Reviewed-by: Johan Helsing <johan.helsing@qt.io> Reviewed-by: Simo Fält <simo.falt@qt.io>
| * Provisioning: Set ssh key and configurations for Yocto buildHeikki Halmet2018-04-151-0/+55
| | | | | | | | | | | | Task-number: QTQAINFRA-1888 Change-Id: I2dd01080998866ce2affd6a5aea797540f28db19 Reviewed-by: Tony Sarajärvi <tony.sarajarvi@qt.io>
| * Provisioning: Upgrade pip to latest versionHeikki Halmet2018-04-154-10/+24
| | | | | | | | | | | | | | | | | | | | | | | | Latest pip version is not installed during python installation. Pip need to be reinstalled after python installation because older version of pip seems to cause installation problems randomly at least with python 2.7 Task-number: QTQAINFRA-1902 Change-Id: If3d74130ecee6e410c64cad309feff9edc0e5db0 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Simo Fält <simo.falt@qt.io>
| * Provisioning: Remove sha1 file after shasum checkHeikki Halmet2018-04-151-0/+1
| | | | | | | | | | Change-Id: Iee8e66d98e5ebd2dee18baf8e1752a86065417d1 Reviewed-by: Tony Sarajärvi <tony.sarajarvi@qt.io>
* | Adjust submodule branchesOswald Buddenhagen2018-04-121-40/+40
|/ | | | Change-Id: Ic069e5dedce639cb1c17df06ee43e87eacc139d8
* Update submodules on '5.11' in qt5Qt Submodule Update Bot2018-04-118-0/+0
| | | | | Change-Id: Ibfd10c0da7c86f52a860cd39776519c9d4ab4b61 Reviewed-by: Qt Submodule Update Bot <qt_submodule_update_bot@qt-project.org>
* Update submodules on '5.11' in qt5Qt Submodule Update Bot2018-04-1010-0/+0
| | | | | Change-Id: I71ed7dbae2d7071e9c16a6e24979174b1b75d640 Reviewed-by: Qt Submodule Update Bot <qt_submodule_update_bot@qt-project.org>
* Update submodules on '5.11' in qt5wip/webassemblyQt Submodule Update Bot2018-04-075-0/+0
| | | | | Change-Id: Ie59c702af192cf03bb5c865345625f61feb83887 Reviewed-by: Qt Submodule Update Bot <qt_submodule_update_bot@qt-project.org>
* Fix msvc_2015_update3_patchOliver Wolff2018-04-061-1/+0
| | | | | Change-Id: Ie008b274c2f27d9792340dd4f6c2d3215bd376ca Reviewed-by: Maurice Kalinowski <maurice.kalinowski@qt.io>
* Remove updating of RHEL 7.4 system during each provisioningTony Sarajärvi2018-04-061-1/+0
| | | | | | | | | | | Yum update doesn't only fetch the repository data. It also runs a distro upgrade. So if something gets updated that isn't compatible with us, it breaks. It also slows down the provisioning a lot. Change-Id: I27136bc572fbce5410b82ff9574cf85bf89e3100 Reviewed-by: Joni Jäntti <joni.jantti@qt.io> Reviewed-by: Heikki Halmet <heikki.halmet@qt.io>
* Update submodules on '5.11' in qt5Qt Submodule Update Bot2018-04-0614-0/+0
| | | | | Change-Id: Ic767892fd0ed815d1cec35eced62e83b1ac4e029 Reviewed-by: Liang Qi <liang.qi@qt.io>
* Add VC build tools to Windows 10 x86 templateJoni Jantti2018-04-061-1/+1
| | | | | | | These tools were missing from the installation. Change-Id: I627b28a6f9373df708952e22a7f404b8dbce6239 Reviewed-by: Heikki Halmet <heikki.halmet@qt.io>
* Update submodules on '5.11' in qt5v5.11.0-beta3Liang Qi2018-04-056-0/+0
| | | | | Change-Id: Ic5b5615653f2fed507c75ca96a05de0affb65863 Reviewed-by: Liang Qi <liang.qi@qt.io>
* Don't require Qt Android Extras for Qt PurchasingEskil Abrahamsen Blomfeldt2018-04-051-2/+2
| | | | | | | | | | Qt Purchasing is supported on other platforms than Android, so move qtandroidextras from depends to recommends instead. Task-number: QTBUG-67318 Change-Id: I9c70574dd9b45579485b2640f7daeebdc6c2bc63 Reviewed-by: Jędrzej Nowacki <jedrzej.nowacki@qt.io> Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@qt.io>
* Add a clean installed Win10_x86 for RTAJoni Jantti2018-04-053-1/+3
| | | | | | Task-number: QTQAINFRA-1842 Change-Id: I0334d74055690c7f850fd105fe008d11a8e57b8c Reviewed-by: Matti Paaso <matti.paaso@qt.io>
* Update submodules on '5.11' in qt5Qt Submodule Update Bot2018-04-046-0/+0
| | | | | Change-Id: I2c8dfa7b7b27e6aa80381761d8b7883690133496 Reviewed-by: Liang Qi <liang.qi@qt.io>
* Update submodules on '5.11' in qt5Qt Submodule Update Bot2018-04-021-0/+0
| | | | | Change-Id: I7e60d0eae7d23fbc2eebf1734c3fd9a713b6b732 Reviewed-by: Qt Submodule Update Bot <qt_submodule_update_bot@qt-project.org>
* Update submodules on '5.11' in qt5Qt Submodule Update Bot2018-04-011-0/+0
| | | | | Change-Id: I7f31b0b19c8380a7f5420917ad7dc423e3ca3658 Reviewed-by: Qt Submodule Update Bot <qt_submodule_update_bot@qt-project.org>
* Update submodules on '5.11' in qt5Qt Submodule Update Bot2018-03-311-0/+0
| | | | | Change-Id: I89c95acfd2ee14574c0ca524d80837023dbc112f Reviewed-by: Qt Submodule Update Bot <qt_submodule_update_bot@qt-project.org>
* Provisioning: Win8.1 - Add jom for RTAJoni Jantti2018-03-302-0/+2
| | | | | | | | Jom is required by RTA. Task-number: QTQAINFRA-1895 Change-Id: Iec99a91d2a48c4c6ef49829e4f05baa90d1a96e0 Reviewed-by: Heikki Halmet <heikki.halmet@qt.io>
* Update submodules on '5.11' in qt5Qt Submodule Update Bot2018-03-309-0/+0
| | | | | Change-Id: I2f7afb1e261e59e527a482983f699402f0d29d85 Reviewed-by: Qt Submodule Update Bot <qt_submodule_update_bot@qt-project.org>
* Update submodules on '5.11' in qt5Qt Submodule Update Bot2018-03-2821-0/+0
| | | | | Change-Id: I77701db7d1955d7309d464ca1597888d98883a30 Reviewed-by: Jani Heikkinen <jani.heikkinen@qt.io>