summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTopi Reinio <topi.reinio@qt.io>2021-03-11 20:49:21 +0100
committerOliver Wolff <oliver.wolff@qt.io>2021-03-25 09:45:24 +0100
commit64d99075c8e12fed654d86b13963bf0408ae75cf (patch)
treef235e121bb7f0a6a7737e38cb55be0a84e0e046b /CMakeLists.txt
parent38c6e944ee32e1a88401b0e64f27a54c0bca676d (diff)
Enable documentation build on non-Windows platforms
Task-number: QTBUG-91743 Change-Id: I278397bf26b8e11076530cb341420f72bda8a435 Reviewed-by: Paul Wicking <paul.wicking@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> (cherry picked from commit 03de877ae8e9da3b2d7b06268a5a2c1156ee50ee)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8226e14..392016c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,18 @@ project(QtActiveQt # special case
LANGUAGES CXX C
)
+if (NOT WIN32)
+ message(NOTICE "Condition \"WIN32\" is not met, enabling documentation build only.")
+ # special case begin
+ set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
+ find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals)
+ qt_build_repo_begin()
+ add_subdirectory(src/activeqt/doc)
+ qt_build_repo_end()
+ # special case end
+ return()
+endif()
+
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core) # special case
find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Qml Quick Gui Widgets PrintSupport) # special case