summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOliver Wolff <oliver.wolff@qt.io>2021-01-19 13:40:55 +0100
committerOliver Wolff <oliver.wolff@qt.io>2021-01-25 08:48:04 +0000
commit1099b093dc9588d67f04d250292832fdb6487eda (patch)
tree3a88645c2add327c7b57e4db1c9a446fb0edb02c /CMakeLists.txt
parenta6dbd427d3fdc76e50063cd13d24347460f6659f (diff)
Skip module build on platform other than Windows
Change-Id: I05d4de0dfa846bb42d7f91b67ca49640aada7b59 Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 14352ff..654fd4d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,11 @@ project(QtActiveQt # special case
LANGUAGES CXX C
)
+if (NOT WIN32)
+ message(NOTICE "Skipping the build as the condition \"WIN32\" is not met.")
+ return()
+endif()
+
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Widgets PrintSupport) # special case
find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Qml Quick) # special case