summaryrefslogtreecommitdiffstats
path: root/examples/activeqt/opengl/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2020-04-28 12:21:03 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2020-05-12 09:11:33 +0200
commit0f1ff389235018f51c3a5e287896bc4ee3e7c1e9 (patch)
tree32891bdbc417fa78f0a1761605b92c917a4eb0cb /examples/activeqt/opengl/CMakeLists.txt
parenta8284209f33eee8a5ecdbb2cce7798e689bc8b5d (diff)
Initial port to cmake
Port the 2 main libraries, examples and tests. Task-number: QTBUG-78167 Change-Id: I0d00c9fa352a96dcd0e1f42d52e6f15680abd9ed Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/activeqt/opengl/CMakeLists.txt')
-rw-r--r--examples/activeqt/opengl/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/examples/activeqt/opengl/CMakeLists.txt b/examples/activeqt/opengl/CMakeLists.txt
new file mode 100644
index 0000000..5c08b0c
--- /dev/null
+++ b/examples/activeqt/opengl/CMakeLists.txt
@@ -0,0 +1,43 @@
+# Generated from opengl.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(openglax LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/activeqt/opengl")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Widgets)
+find_package(Qt6 COMPONENTS AxServer)
+find_package(Qt6 COMPONENTS OpenGL)
+find_package(Qt6 COMPONENTS OpenGLWidgets)
+
+add_qt_gui_executable(openglax
+ glbox.cpp glbox.h
+ globjwin.cpp globjwin.h
+ main.cpp
+)
+target_link_libraries(openglax PUBLIC
+ Qt::AxServer
+ Qt::Core
+ Qt::Gui
+ Qt::OpenGL
+ Qt::OpenGLWidgets
+ Qt::Widgets
+)
+
+install(TARGETS openglax
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)