summaryrefslogtreecommitdiffstats
path: root/examples/activeqt/qutlook/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2021-07-28 13:09:02 +0200
committerAlexey Edelev <alexey.edelev@qt.io>2021-07-28 15:47:05 +0200
commit934bb86f9bb6c8f36e87097c8d74effc13e08f10 (patch)
tree449b495cb8e398b41f796b5d32a5d823ba587175 /examples/activeqt/qutlook/CMakeLists.txt
parentd362c6ac38c9056eadc78b985ec13d2d1120a8bb (diff)
Fix type library UUID regex
CMake doesn't support regex quantifiers, so need to multiply the number of hexadecimal numbers manually in UUID regex. Add missing LIBRARIES argument to qutlook example. Fixes: QTBUG-95407 Pick-to: 6.2 6.1 Change-Id: I3f3da1e29fe524ed7f03b3764de9139c4fc13a5b Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/activeqt/qutlook/CMakeLists.txt')
-rw-r--r--examples/activeqt/qutlook/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/examples/activeqt/qutlook/CMakeLists.txt b/examples/activeqt/qutlook/CMakeLists.txt
index 5e009fa..6994f37 100644
--- a/examples/activeqt/qutlook/CMakeLists.txt
+++ b/examples/activeqt/qutlook/CMakeLists.txt
@@ -30,7 +30,7 @@ set_target_properties(qutlook PROPERTIES
MACOSX_BUNDLE TRUE
)
-qt6_target_typelibs(qutlook "msoutl:{00062FFF-0000-0000-C000-000000000046}")
+qt6_target_typelibs(qutlook LIBRARIES "msoutl:{00062FFF-0000-0000-C000-000000000046}")
target_link_libraries(qutlook PUBLIC
Qt::AxContainer