summaryrefslogtreecommitdiffstats
path: root/examples/activeqt/simple/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2021-04-13 18:55:01 +0200
committerAlexey Edelev <alexey.edelev@qt.io>2021-04-27 15:53:33 +0200
commitc4623d4296f0a5502cba5f2395b97bd28a83dd6f (patch)
tree0e5321aab1fe8c45110c8046e3b15db7792e134a /examples/activeqt/simple/CMakeLists.txt
parentbc04ce3195048a8e236aa510a7a1e6ffa4b742c5 (diff)
Update tests and examples to use the new '_axserver_' functions
Use the new '_axserver_' function in tests and examples associated to creating of the ActiveX sever. Squash find_package calls. Change-Id: Iacdba7b673ae9cfcc7d9e1ff82d0884e330166ab Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/activeqt/simple/CMakeLists.txt')
-rw-r--r--examples/activeqt/simple/CMakeLists.txt15
1 files changed, 4 insertions, 11 deletions
diff --git a/examples/activeqt/simple/CMakeLists.txt b/examples/activeqt/simple/CMakeLists.txt
index 12fd293..283edc6 100644
--- a/examples/activeqt/simple/CMakeLists.txt
+++ b/examples/activeqt/simple/CMakeLists.txt
@@ -15,20 +15,13 @@ endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/activeqt/simple")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
-find_package(Qt6 COMPONENTS AxServer)
-
-qt_add_executable(simpleax
+find_package(Qt6 COMPONENTS Core Gui Widgets AxServer)
+qt6_add_axserver_executable(simpleax
main.cpp
-)
-set_target_properties(simpleax PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
+ simple.def
+ simple.rc
)
target_link_libraries(simpleax PUBLIC
- Qt::AxServer
Qt::Core
Qt::Gui
Qt::Widgets