summaryrefslogtreecommitdiffstats
path: root/examples/activeqt/qutlook/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/activeqt/qutlook/CMakeLists.txt')
-rw-r--r--examples/activeqt/qutlook/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/examples/activeqt/qutlook/CMakeLists.txt b/examples/activeqt/qutlook/CMakeLists.txt
index af1de27..5e009fa 100644
--- a/examples/activeqt/qutlook/CMakeLists.txt
+++ b/examples/activeqt/qutlook/CMakeLists.txt
@@ -20,11 +20,18 @@ find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Widgets)
find_package(Qt6 COMPONENTS AxContainer)
+qt_add_executable(qutlook
+ addressview.cpp addressview.h
+ main.cpp
)
+
set_target_properties(qutlook PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
+
+qt6_target_typelibs(qutlook "msoutl:{00062FFF-0000-0000-C000-000000000046}")
+
target_link_libraries(qutlook PUBLIC
Qt::AxContainer
Qt::Core
@@ -32,13 +39,6 @@ target_link_libraries(qutlook PUBLIC
Qt::Widgets
)
-if(NOT TYPELIBS_ISEMPTY)
- target_sources(qutlook PUBLIC
- addressview.cpp addressview.h
- main.cpp
- )
-endif()
-
install(TARGETS qutlook
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"